Question

DO Droplet Performs Differently than other Servers - With errors

Ok… this is an odd one…

  1. I am attempting to access a 3rd party api
  2. when i pass my curl command locally to the api > all is well
  3. when i pass same exact command from any DO droplet, I get an error.
  4. I tried different flavors: ubuntu, centos and debian. i tried NY, Frankfort and Bangalor…all DO droplets > same error.
  5. from any desktop anywhere >> no error
  6. so i decided to rent a VPS from another competitor of DO, >>no error
  7. how is this possible? what could DO do that makes their servers throw a cURL error?
image alt text
error

Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

If a DigitalOcean (DO) Droplet is performing differently or encountering errors compared to other servers, there could be various reasons behind the discrepancies. Here are some common issues and troubleshooting steps you can take to address them:

  1. Server Specifications: Ensure that the DO Droplet’s hardware specifications (CPU, RAM, Disk) are comparable to the other servers you are comparing it with. Inadequate resources may lead to performance differences.

  2. Load and Traffic: Check if there is a difference in the load and incoming traffic between the DO Droplet and other servers. Higher traffic can impact performance and cause errors.

  3. Network Connectivity: Verify if there are any networking issues that could affect the DO Droplet’s performance. Check network latency, packet loss, and firewall settings.

alexdo
Site Moderator
Site Moderator badge
July 17, 2023

Heya @fasbit0e6299492ed096cf92da

You can check if your droplet can correctly resolve the API’s domain by using curl or nslookup commands.

If your desktop successfully connects to the API through a VPN or Proxy, your droplet might not be whitelisted by the API provider. You can check this by reaching out to the API provider.

This can also be a Firewall issue, so you can ensure that no outbound connections are being blocked by your droplet’s firewall. You can check this by using the iptables or ufw commands.

Hope that this helps!

KFSys
Site Moderator
Site Moderator badge
July 17, 2023

Hey @fasbit0e6299492ed096cf92da,

It’s unusual to be honest however there are a couple of things you can check:

Check your Firewall: When you create a Droplet check if the UFW firewall is active and if it’s allowed on the port you are using your API ** Try Telnet**: When you SSH to your Droplet try to use telnet to connect to the API to see if that is possible.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel