Question

Docker deploy to app platform failed with error related to image

After successfull deployments, new one failed with error message

13:28:20 INFO[0020] Found cached layer, extracting to filesystem 
13:28:20 error building image: error building stage: failed to execute command: extracting fs from image: removing whiteout .wh.tmp: unlinkat //tmp: device or resource busy
13:28:20 exit status 1
13:28:20  ! Build failed (exit code 1) 

There weren’t any changes to dockerfile in project. How it could be fixed?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This looks like an internal bug. I’m an engineer on our App Platform team and have filed a ticket to track this internally. In the mean time I recommend triggering a rebuild by using the “Deploy” button in the top right.

Same problem for me. I had to change Dockerfile RUN statement to invalidate cache layer and the next deploy was successful

If you are using the “ADD” command change it to “COPY” in your Dockerfile.