Question

docker deploying to DigitalOcean App returns this error in log at the end - cannot find module './lib/pdf'

I tried connecting a forked repo - https://github.com/anjanesh/quickchart - to a DO App which failed to build at the end.

[quickchart] [2021-11-27 06:49:59] => Uploaded the built image to the container registry
[quickchart] [2021-11-27 06:49:59] => Build complete
[quickchart] [2021-11-27 06:50:54] {"name":"quickchart","hostname":"quickchart-77xxx-xxx","pid":1,"level":30,"msg":"Telemetry is enabled","time":"2021-11-27T06:50:54.083Z","v":0}
[quickchart] [2021-11-27 06:50:54] internal/modules/cjs/loader.js:818
[quickchart] [2021-11-27 06:50:54]   throw err;
[quickchart] [2021-11-27 06:50:54]   ^
[quickchart] [2021-11-27 06:50:54]
[quickchart] [2021-11-27 06:50:54] Error: Cannot find module './lib/pdf'
[quickchart] [2021-11-27 06:50:54] Require stack:
[quickchart] [2021-11-27 06:50:54] - /quickchart/index.js
[quickchart] [2021-11-27 06:50:54]     at Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)
[quickchart] [2021-11-27 06:50:54]     at Function.Module._load (internal/modules/cjs/loader.js:667:27)
[quickchart] [2021-11-27 06:50:54]     at Module.require (internal/modules/cjs/loader.js:887:19)
[quickchart] [2021-11-27 06:50:54]     at require (internal/modules/cjs/helpers.js:74:18)
[quickchart] [2021-11-27 06:50:54]     at Object.<anonymous> (/quickchart/index.js:11:55)
[quickchart] [2021-11-27 06:50:54]     at Module._compile (internal/modules/cjs/loader.js:999:30)
[quickchart] [2021-11-27 06:50:54]     at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
[quickchart] [2021-11-27 06:50:54]     at Module.load (internal/modules/cjs/loader.js:863:32)
[quickchart] [2021-11-27 06:50:54]     at Function.Module._load (internal/modules/cjs/loader.js:708:14)
[quickchart] [2021-11-27 06:50:54]     at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12) {
[quickchart] [2021-11-27 06:50:54]   code: 'MODULE_NOT_FOUND',
[quickchart] [2021-11-27 06:50:54]   requireStack: [ '/quickchart/index.js' ]
[quickchart] [2021-11-27 06:50:54] }

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey there!

From your logs it looks like that module isn’t being installed. Not sure if that requires a specific version of node and npm to work correctly. I’d recommend reaching out to the developer of that repo and verify the run requirements for that module.

Hope it helps! Nate