Dokku hanging after Docker update

  • Posted January 16, 2014

Today I wanted to take a stab at getting a rails app deployed with dokku, so I followed the walkthrough found here (

When I try to run dokku postgresql:create app_name it advises me to update docker.

I update docker following the directions found here

I then create the database.

Now when I try git push dokku master it just hangs…

Anyone run into issues with this?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I had the same problem and found a solution. When I ran dokku postgresql:create app_name, I got the “please update” notice, but actually when I looked in docker containers, the postgresql/app_name got created. Dokku just didn’t see it as its own. So I went nano /home/dokku/app_name/ENV and set my DATABASE_URL environment variable to


according to link. Then when I pushed the app again to dokku, it got the database from the ENV and everything worked smoothly.

Can you point to a tutorial please? I’m having a ‘Your docker version is too old, please update it’ even after apt-get install upgrade…

I ended up doing a manual install of Dokku on a fresh Ubuntu 13.04 to work around this. It’s actually quite easy and works without issue.

A number of the tutorial examples use Kloadut’s PostgreSQL plugin for Dokku, which now requires Docker version 0.7.2 or higher, but the one click app installs Docker version 0.6.6. Is there a way to work around this?

Dokku probably doesn’t support the version of docker you updated to. Does it work on the “old” version?