Dokku password prompt even after setting up ssh keys

May 5, 2015 5.7k views
Dokku Git


I'm posting a question here as a last resort, before I throw my computer against the wall (not really), after multiple failed attempts to deploy a Django app through the preconfigured dokku droplets.

I have gone through several droplets, created, destroyed, spent hours going through forums, blogs and stackoverflow, but no matter what I've done I still get stuck at the very last stage -that damn password.

The website I've been using this tutorial LINK but always get stuck at

git push production master

I've added my local (Macbook) public key ( to both the root and dokku users, and am able to ssh into them without password prompts. I've configured my git account (git --global?) correctly. I've used

cat ~/.ssh/ | ssh root@your.dokku.ip "sudo sshcommand acl-add dokku [description]"

but again, no matter what I do, I still get the password prompt.

HELP!!!!! What am I doing wrong? Any and all help would be really appreciated.

Thank you in advance...

EDIT: Forgot to ask... What about adding the root ssh key to the dokku user's authorized hosts?
I've also added the root key to my github account...

  • When you ran:

    cat ~/.ssh/ | ssh root@your.dokku.ip "sudo sshcommand acl-add dokku [description]"

    Did you change description to a single word like "personal" or "home"?

  • @chaseadamsio yep... tried [macbook] and and macbook and "macbook", with no luck.
    Thanks for replying!

  • Weird. I ran into this issue this morning on a fresh Dokku instance and that fixed it for me. So your remote look like (when doing git remote -v:

    production dokku@[whateveryoururlIs]:[whateverYourRemoteDokkuRepoIs] 

    and when you try to do a push with git push production master you still get a prompt for password?

  • I'm having the same problem. Not sure how to proceed. Anyone get a fix for this yet?

  • same problem here!! anyone from DO can make a response?

  • having the same issue.

  • So, it seems that this command is outdated:

    cat ~/.ssh/ | ssh root@your.ip.address "cat >> ~/.ssh/authorized_keys"

    But this works for me:

    cat ~/.ssh/ | ssh root@your.ip.address "sudo sshcommand acl-add dokku [description]"
  • Same issue...

  • Any progress on this? Seems like a very common problem with no reliable solution.

    I ran cat ~/.ssh/ | ssh root@my.dokku.ip "sudo sshcommand acl-add dokku firstdokku"

  • I've got an answer below - basically you have to tell git to use ssh!

9 Answers

I have the same problem.. Can't resolve during 2 days =(

spent a few hours tuning SSH & Dokku, but still cant make it work for me
Could anyone look into this issue?

I had the same problem, and it was because I had a misconfiguration inside ~/.ssh/config

Ok, it is the way how i resolved the problem:

  1. Open config file in .ssh folder
  2. Add '.pub' to IdentityFile
  3. save file and try to do "ssh root@[droplet id]"
  4. you will get error
  5. remove '.pub' from config file
  6. do "ssh root@[droplet id]"
  7. in new terminal tab try to push remote branch

I hope it will help somebody =)

For those still getting this problem try updating your ~/.git/config with:

IdentityFile ~/.ssh/id_rsa(.pub)
User dokku

Make sure you add your SSH key to the authorized_keys for the dokku user as well as root! i.e. in /home/dokku/.ssh/authorized_keys

Have another answer? Share your knowledge.