Dokku password prompt even after setting up ssh keys


I’m posting a question here as a last resort, before I throw my computer against the wall (not really), after multiple failed attempts to deploy a Django app through the preconfigured dokku droplets.

I have gone through several droplets, created, destroyed, spent hours going through forums, blogs and stackoverflow, but no matter what I’ve done I still get stuck at the very last stage -that damn password.

The website I’ve been using this tutorial LINK but always get stuck at

git push production master

I’ve added my local (Macbook) public key ( to both the root and dokku users, and am able to ssh into them without password prompts. I’ve configured my git account (git --global?) correctly. I’ve used

cat ~/.ssh/ | ssh root@your.dokku.ip "sudo sshcommand acl-add dokku [description]"

but again, no matter what I do, I still get the password prompt.

HELP!!! What am I doing wrong? Any and all help would be really appreciated.

Thank you in advance…

EDIT: Forgot to ask… What about adding the root ssh key to the dokku user’s authorized hosts? I’ve also added the root key to my github account…

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Make sure you add your SSH key to the authorized_keys for the dokku user as well as root! i.e. in /home/dokku/.ssh/authorized_keys

For those still getting this problem try updating your ~/.git/config with:

IdentityFile ~/.ssh/id_rsa(.pub)
User dokku

Ok, it is the way how i resolved the problem:

  1. Open config file in .ssh folder
  2. Add ‘.pub’ to IdentityFile
  3. save file and try to do “ssh root@[droplet id]”
  4. you will get error
  5. remove ‘.pub’ from config file
  6. do “ssh root@[droplet id]”
  7. in new terminal tab try to push remote branch

I hope it will help somebody =)