Dokku www subdomain

May 11, 2014 4.1k views
I have set up dokku on digital ocean and deployed my first site successfully like this: git remote add dokku dokku@myfirstdomain.com:myfirstdomain.com git push dokku master I can access this first site by visiting either http://www.mydomain.com or http://mydomain.com I have set up my second site in the same way git remote add dokku dokku@myseconddomain.com:myseconddomain.com git push dokku master I can access my second site by going to http://myseconddomain.com but when I try to access using http://www.myseconddomain.com it shows the site from myfirstdomain.com How do I set up the www subdomain so http://www.myseconddomain.com correctly loads the myseconddomain content? I have pointed the * A record and @ A record of both domains to the ip address of my droplet
9 Answers

I have very similar problem

I have myapp.com deployed on dokku and I NEED www.myapp.com subdomain to point to the same app.

also I have foo.myapp.com (deployed on dokku) but somehow www.myapp.com always points to this app instead of root..

Did you manage to workaround this?

quick question how did u copy the key to dokku before git push?

cat ~/.ssh/id_rsa.pub | ssh root@myfirstdomain.com:myfirstdomain.com "sudo sshcommand acl-add dokku myfirstdomain.com" ?

Check your webserver configuration file, or if you want post it here to help you.
@maestrrr I copied from .ssh/id_rsa.pub and pasted in the input field that you get when first setting up Dokku.
@jamie: You might want to check out the dokku-domains-plugin:

I tried dokku-domains-plugin but didn't seem to work.

So in nginx.conf for my second app I changed

server_name myseconddomain.com;


server_name myseconddomain.com www.myseconddomain.com;

I think this should be fine when I push changes but as I understand will no longer work if I delete my second app and add back again? - I am new to nginx / dokku so just feeling my way at the moment
Ok it turns out that eveytime I push this get overwritten. SO need another solution

For other folks who may run into this, this should solve the issue:

domains:add name_of_site www.domainname.extension

And, if you happen to be running Django, be sure to add ".domainname.extension" to your ALLOWED_HOSTS settings.

Have another answer? Share your knowledge.