Question

Domain and IP not working

Hello, today I deployed my my site using Gitlab CI/CD, however, the domain doesn’t display it www.whatwewantdoesntexist.com and the following error pops up: refused to connect. ERR_CONNECTION_REFUSED. Additionally, I cannot connect to my IP address either and it shows the same error. The domain points to the right IP address

I’m not sure what’s causing this error. Any ideas, please?

firewall: To Action From


22/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
22/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I would recommend connecting to your Droplet via SSH and checking if your Docker container is actually running and also checking your ports.

  • Check if the container is running:
docker ps -a
  • If the container is not running check your Docker logs:
docker logs CONTAINER_ID
  • Also to check the ports that are being used on your droplet run the following:
netstat -plant

Note that you might have to either expose the Docker container port so that it is available and you could access it or maybe install Nginx and use it as a reverse proxy.

Hope that this helps! Regards, Bobby