I’ve configured my domain following this tutorial.

It seems work, but after moments it goes to IP address and the other pages have IP address rather than my domain :(

Anyone has same problem?

I’ve tested below device list.

mac chrome (fail - Version 54.0.2840.71 (64-bit))
https://giphy.com/gifs/JyCq7NIIkASBi
mac safari (success - Version 10.0.1 (11602.2.14.0.7))

iphone chrome (success - 54.028)
iphone safari (fail - ios10)

LG Tab..firefox (fail)
https://giphy.com/gifs/oV1ZMZpV45rR6

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hey there,

What software are you using for your web server? Nginx, Apache, HAProxy?

If you’re using nginx, could it be possible that in one of your blocks you’ve bound the server-block to your IP address (instead of 0.0.0.0) and then you’re redirecting to $host?

If you drop your server block below (for whatever web server you’re using), we’ll be able to help :)

This is my /var/apache2/sites-available/000-default.conf file.


<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        <Directory /var/www/html/>
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>
</VirtualHost>

This is my /var/apache2/sites-available/default-ssl.conf file.

<IfModule mod_ssl.c>
        <VirtualHost _default_:443>
                ServerAdmin webmaster@localhost

                DocumentRoot /var/www/html
               <FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>
        </VirtualHost>
</IfModule>

Is it enough? or could you specify the path to get blacklist of my server?

Submit an Answer