kryptics
By:
kryptics

domain.com not working, but www.domain.com working? where did i go wrong?

January 15, 2017 155 views
Apache CentOS

So my site www.kryptics.net is working fine, however my kryptics.net somehow it goes to an existent root folder? where did i go wrong? any help is appreciated, thanks
http://tinypic.com/r/i6b3oj/9
http://tinypic.com/r/ibmc0y/9
http://tinypic.com/r/4kzgu8/9

4 Answers

@kryptics

Your DNS looks good, so my first recommendation would be to check your Apache VirtualHost setup and make sure that www is setup as a ServerAlias. You need both a valid DNS entry (which you have) and a ServerAlias targeting the www alias.

So if we look at your VirtualHost configuration, you should see something like:

ServerName kryptics.net

And you need to add a ServerAlias entry for it:

ServerName kryptics.net
ServerAlias www.kryptics.net

Then restart Apache.

You'll also want to make sure that your SSL certificate is setup to handle your domain with and without the www.

Oh thats weird looks like i had them inverted...

ServerName www.kryptics.net instead of
ServerName kryptics.net

I'll try that.. thanks!

The Apache web server is extremely powerful and flexible, which is why it's the most popular way of serving web content. Apache can host multiple domains or interfaces on one server by splitting sites into separate virtual hosts. In this guide, we will walk you through how to set up Apache virtual hosts on a CentOS 7 VPS.

can't take it, going to start from scratch... lol - thanks for trying to help :)

Have another answer? Share your knowledge.