I have created a dash web app and used Apache server to deploy it.When I go to my url, www.urlname.com , it directs to IP address and IP address is shown in the search bar.Can anyone help me how to make sure that it shows the URL ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @yahoo1294,

It seems like you haven’t configured properly your Apache Virtual Configuration or added an .htaccess redirect.

Firstly,I’ll recommend checking out the /etc/apache2/sites-available/example.com.conf where example.com will need to be replaced with your domain name. There you might have created a redirect to your IP address. If you are unsure what changes to do, I’ll recommend checking out the following Apache article:

https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

If you are still unsure afterwards, I’ll recommend posting your config here so that we can assist you with it.

Another possibility would be your .htaccess having a redirect to your IP address. The .htaccess will be placed in your website’s document root. I’ll recommend checking out there.

Regards,
KDSys

by Lisa Tagliaferri
This tutorial will guide you through setting up multiple domains and websites using Apache virtual hosts on an Ubuntu 18.04 server. During this process, you’ll learn how to serve different content to different visitors depending on which domains they are requesting.
Submit an Answer