Question

Domain name not working (blank page)

Hello everyone,

I’m trying to setup a domain name purchased on GoDaddy with my DigitalOcean droplet. So far, here’s what I’ve done :

  • Added the DigitalOcean nameservers (NS) in the Godaddy panel

  • Setup the domain in DigitalOcean for my droplet

If I ping the domain name charlesdemers.com, here’s what I get :

PING charlesdemers.com (45.55.239.198): 56 data bytes
64 bytes from 45.55.239.198: icmp_seq=0 ttl=54 time=32.050 ms
64 bytes from 45.55.239.198: icmp_seq=1 ttl=54 time=31.006 ms
64 bytes from 45.55.239.198: icmp_seq=2 ttl=54 time=30.818 ms
64 bytes from 45.55.239.198: icmp_seq=3 ttl=54 time=32.044 ms

The IP adress is correct, it’s pointing to my droplet’s IP. However, if I try to access the website by typing the domain name, it won’t work. I only get a blank page.

If I type the IP adress its pointing to directly, it works though.

Any idea on what I’m doing wrong? Am I missing a key step?

Thank you all for your help.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Sure,

You need Apache2

sudo apt-get install apache2

Then

cd /etc/apache2/sites-enabled
nano 000-default.conf

Check if you see this

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Everything should work fine. If you still see a blanc page, wait 24h (DNS need some time)

You save HTML files here : /var/www/html

If you need PHP and MySQL just ask

Dns can take anywhere from 30 min - 48 hours, most of the time its pretty quick but for some people it has taken 48 hours, your just at the mercy of how busy the internet is

Your domain works, it was DNS, it takes some time