Question

Domain name not working while IP does. (Apache2)

Unable to access the website through domain name (http://waybesite.com) while it is working fine on http://157.245.105.185/. I have made the changes expected (ServerName and Virtualhost) in the apache2.conf and waybesite.com.conf file. Please help as I am stuck on this for almost 3 days. Thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @ngandamalla,

As far as I can see the error that you are getting is:

Untrusted Host "waybesite.com".

To fix that error you need to add your domain name to the trusted hosts list. For example if you are using Symfony, you can do that by updating your framework.yaml file and adding the domain name to the trusted_hosts array.

Once you have the domain name added to the trusted hosts, it will work as normal.

Regards, Bobby