Domain not linking to IP.

September 5, 2014 988 views

So I have created a droplet hosting wordpress, and I have configured all the hostnames to the name of the domain, I have also updated the name servers on my registrar, and followed all the tutorials on how to create the domain link in the dns settings, etc. Nothing seems to work, when I try to edit the 'general settings' on wordpress and put my domain there it completely breaks the site, and I have to manually reupdate the settings back to the IP address through ssh.

Definitely missing something obvious here and could use some help, thanks!

Oh, and I've also tried clearing my dns cache, nothin'.

1 comment
  • (If you're on Linux/Mac), try putting:


    in the terminal. Do you get anything back? It should say something like has address x.x.x.x (where x.x.x.x matches the IP of your droplet).

    If that's working, then chances are there's a configuration problem with your web server. Are you using Apache, or nginx?

1 Answer
Have another answer? Share your knowledge.