Domain only works with "www." in front

May 1, 2019 207 views
DNS

Hi,

I recently purchased a Droplet and I’m really enjoying the speed of it. However, my domain isn’t accessible unless you type “www.” in front of the URL. For example, www.meneergadget.nl works, but meneergadget.nl or https://meneergadget.nl doesn’t.

I have used the DigitalOcean nameservers on the DNS settings for my registrar and this is what my settings look like: https://i.imgur.com/O56UUJJ.png

Hope someone can help me.

2 Answers

@kiwohs

Thanks for posting this question, I think you have a problem with your web server setup if you are using apache web server you need to add these two directives so your website will work with and without www.

ServerName meneergadget.nl
ServerAlias www.meneergadget.nl

Then restart apache sudo systemctl restart apache2

Hope this helps.

Then restart apache sudo systemctl restart apache2

Have another answer? Share your knowledge.