Question

Droplet access issue

Posted January 24, 2021 211 views
Nginx

I am able to access my droplet using a mobile network via WinSCP but when I am trying to connect my droplet using a wifi network via the same (WinSCP) and same configuration then it is not connecting. Could anyone please help me with this?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi there,

Is sounds like that you might have a firewall on your Droplet. I could suggest checking the public IP address of your Wi-Fi and allowing it on your Droplet.

If this is not the case, I could suggest running a traceroute or an MTR from your PC, while connected to your Wi-Fi`, to your Droplet. That way you will be able to see where exactly the connection is failing.

Let me know how it goes.
Regards,
Bobby

  • C:\Users\PRRAKSHA>ping 157.245.241.231

    Pinging 157.245.241.231 with 32 bytes of data:
    Reply from 157.245.241.231: bytes=32 time=305ms TTL=48
    Reply from 157.245.241.231: bytes=32 time=313ms TTL=48
    Reply from 157.245.241.231: bytes=32 time=368ms TTL=48
    Reply from 157.245.241.231: bytes=32 time=351ms TTL=48

    Ping statistics for 157.245.241.231:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 305ms, Maximum = 368ms, Average = 334ms


    But when I am trying to connect WinSCP is giving an error - Network error: Connection to “157.245.241.231” timed out.


    It happens only when I am trying with wifi otherwise it’s working fine with a mobile hotspot.

    • Hello,

      Yes, the ping output confirms that it looks like that either your IPS is blocking the traffic to your Droplet or you have a firewall on your Droplet that is stopping the traffic.

      I would recommend running tracert or MTR instead so that you could see where the connection is being dropped at.

      Regards,
      Bobby

      • This is MTR report of my Laptop

        |------------------------------------------------------------------------------------------|
        |                                      WinMTR statistics                                   |
        |                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
        |------------------------------------------------|------|------|------|------|------|------|
        |                             192.168.0.1 -    0 |    8 |    8 |    2 |   10 |   66 |    2 |
        |                             10.25.119.1 -    0 |    8 |    8 |    3 |   15 |   68 |    5 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |dynamic-121.178.225.103.sitibroadband.in -    0 |    8 |    8 |   15 |   23 |   79 |   15 |
        |                             172.31.1.66 -    0 |    8 |    8 |   14 |   23 |   79 |   14 |
        |                          182.73.243.165 -    0 |    8 |    8 |   40 |   62 |  196 |   41 |
        |                          182.79.222.237 -    0 |    8 |    8 |  258 |  278 |  378 |  268 |
        |                 UnAssigned170.nyiix.net -    0 |    8 |    8 |  259 |  278 |  378 |  259 |
        |                           138.197.244.6 -    0 |    8 |    8 |  249 |  274 |  377 |  251 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |                   No response from host -  100 |    1 |    0 |    0 |    0 |    0 |    0 |
        |                         157.245.241.231 -    0 |    8 |    8 |  240 |  258 |  378 |  242 |
        |________________________________________________|______|______|______|______|______|______|
           WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
        
        edited by bobbyiliev
        • Hi there,

          It looks like that the Loss % is at 0, are you still seeing the problem?

          If you have a firewall on your Droplet like CSF for example, make sure to allow your Wi-Fi public IP address.

          Regards,
          Bobby

          • yes, wifi public IP is allowed. I have a digital ocean ubuntu 16 droplet. could you please suggest to me the command to check and update this if it blocks from the droplet firewell?

          • Hi there,

            What is the firewall that you are currently using?

            If you are using fail2ban, you can check that by running this command:

            sudo zgrep 'Ban' /var/log/fail2ban.log*
            

            If you are using CSF you can do that with:

            sudo grep -r your_public_ip /etc/csf/*
            

            Another thing that I could suggest as a test is to spin up a Droplet in the same region as your current one and try to access it via your Wi-Fi as a test to see if your ISP is blocking the connections.

            Let me know how it goes!
            Regards,
            Bobby

this is a little important, please help me to fix this issue. I don’t know much about droplet and Linux.

  • @bobbyiliev Thanks for your co-operation. above both command is not working in my droplet console. Could you please let me know the command for Ubuntu 16 or the location of any file that we have open and see/update to fix this issue?

    • Hi there @PriyeRakshakar,

      In this case, it sounds like your Droplet is not using Fail2Ban and CSF. What is the firewall that you are using?

      Regards,
      Bobby

      • Hi @bobbyiliev
        Thanks for your suggestion. I had raised the request in digital Ocean regarding this and they have done some MTR and told me that it is an issue with my WiFi ISP. I had raised the request with my ISP also and they have enabled port 22 and now it’s working now.

        I am very happy to see your immediate response. Thank you for your help!

        Many Thanks
        Priye Rakshakae

      • Hi there @PriyeRakshakar,

        No problem at all! I am very happy to hear that you’ve got it all working now!

        Regards,
        Bobby