Droplet can not find my spaces host

Posted February 9, 2021 272 views
UbuntuDNSUbuntu 18.04DigitalOcean Spaces

Sometimes my droplet with Ubuntu 18.04 loses connection with spaces:

ping: Name or service not known

It almost completely breaks my site.

If I flush DNS cache with sudo systemd-resolve --flush-caches it helps for a few minutes and then doesn’t work again.

After some time, probably more than an hour, everything starts working just fine.

Has anyone encountered such a problem?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Hi there,

Did you experience this just today? As far as I can see there has been scheduled network maintenance reported on the status page:

If this is happening regularly, have you tried pining other domains during this time to identify if it is a problem specifically with the spaces hostname or DNS lookups in general?


  • Hello! Thanks for your reply!

    It happens today at 14:35 UTC and at February 4.

    I also tried to ping and other sites from the droplet and it works.

    Furthermore, during incident I can successfully ping Spaces host from my home.

    That’s why it’s so mysterious to me.

    Now I just wrote the Spaces IP-address in the /etc/hosts but I’m sure it’s not a good solution.

    In /etc/netplan/50-cloud-init.yaml I have predefined nameservers from DO


    In general, it seems that records about my spaces are being lost from time to time. I don’t know if this is possible at all.