mosaic
By:
mosaic

Droplet Caught In A Loop

April 7, 2017 856 views
WordPress Backups

Hi,

I created a ‘template droplet’ site last week, which was a clean installation of Wordpress including my most used plugins. I then created a snapshot of my 'template droplet' so that I could spin up a droplet from this 'template droplet'.

I created a new droplet from the 'template droplet' yesterday, and it seems like it inherited the IP address from the 'template droplet' in the Wordpress settings. So now when i try to access the base template the new site loads. I’ve logged into the new site backend and updated the wordpress settings to use the new droplet IP address… BUT now i can’t access either site… they are stuck in a loop. I have since powered down the new droplet so that it does not exist, but i still cannot access the 'template droplet' .

Questions

01 - how can I resolve this issue?

02 - how can I spin up a new droplet from the snapshot without this happening again?

Any help at all on this would be greatly appreciated. I am also willing to pay someone for their time / help with this - thank you.

3 Answers

@mosaic

If you installed WordPress using an IP, then WordPress will use that IP and store it during the install as the "domain" (since you're not using a domain). When you restore the snapshot to a new Droplet, it's not changing the fact that you installed WordPress using the previous IP.

To force change this, you'd need to open wp-config.php each time you restore and add:

define('WP_HOME','http://NEW_IP');
define('WP_SITEURL','http://NEW_IP');

Where NEW_IP is the IP of the new Droplet. You'd then refresh the page and it'll use the IP you just set.

@jtittle thank youbfor your help.

I have a few questions on this.

01 - I thought logging into /wp-admin on the new droplet and setting the new IP in Wordpress Settings would work?

02 - If I change the IP address in wp-config, do also need to set the new IP address in Wordpress settings?

03 - I have turned the new droplet off, hoping that the template droplet would then load but I'm still getting a 301... how could I resolve this?

Thanks again for your help, it's much appreciated.

  • @mosaic

    1). You can use that method as well. Setting the constants simply enforces the changes in the event that doesn't work.

    2). I prefer to use constants in ./wp-config.php over ./wp-admin. Sometimes setting the changes in ./wp-admin doesn't work, the constants pretty much always work.

    3). Delete your .htaccess file, login to ./wp-admin, navigation to 'Permalinks' and simply click 'save'. That'll generate a new .htaccess file for you.

    Generally an issue with .htaccess -- whether it's an extra space in the wrong place, or a new line in the wrong place -- can cause errors.

    If that doesn't work, try checking the error log:

    tail -20 /var/log/apache2/error.log
    

    Then paste the output to a code block as a response.

@jtittle thanks for your help.

Here is my feedback.

01 - i deleted the htaccess file on the template droplet and the IP /wp-admin and it still redirects to the new droplet

02 - i've checked /wp.config.php and there is no IP address listed anywhere in this file

Happy to pay for your time to help with this... thanks again.

  • @mosaic

    I can take a look if you'd like for me to. My e-mail is in my profile here on the community, just click on my username (try to keep it out of posts to keep the spam from bots minimal :) ).

    I'll need root access to the Droplet, paths to where your files are stored, and any other relative information. I don't need the database username, password, etc though -- that's all in the config file so if needed, I can check there for that.

Have another answer? Share your knowledge.