Droplet is unbootable

April 10, 2018 355 views
DigitalOcean Backups Ubuntu

My droplet does not start: /
I restored a backup and it still shows the same error as the attached image.
Can someone help me?

Image

2 Answers

I wasted a couple of hours on this yesterday. Go to your droplet settings, select the Kernel tab. DO will claim that you have some kind of Grub Loader kernel active — select another kernel from the list. I think any ubuntu will work, but if you select a different one than you had, some of the software might need an upgrade. Mine was Ubuntu 12.04 x64 3.13.0-32-generic for example.

If you have enough patience to scroll through all that list one of them should in fact be greyed out and selected. You cant choose that one, but select one next to it, hit „Change”, then select back the one you should have and reboot. That fixed it for me.

The other way to do it would be to select any kernel with matching architecture (32 vs x64), reboot, log in and determine what kind of kernel headers were installed on the system, so you can know for sure what kernel to select. YMMV.

Hope this helps.

Can't boot a recovery kernel. Can't boot with my original kernel setting either (DO grub v.0.2) It gets as far as trying to mount the root disk which it can't find. At least the console works again to see the failure (that was broken for a while). Also I could not power cycle for a while, now I can power cycle.

But still winds up in the state where it drops to the initramfs prompt where I can look at /proc/cmdline and see the UUID of the root disk it wants to mount. That fails because /dev/disk/by-uuid/(long UUID) does not exist.

I just tried a random 14.04 kernel as suggested by Puck above. Once I selected the correct arch (64) that worked great. Thanks!

Have another answer? Share your knowledge.