I have setup 3 ubuntu 20.04 droplet, I’m trying to setup mongodb replica-set on 3 droplet,
I have installed mongodb using apt, setup /etc/hosts and it works
but suddenly all 3 droplet have no ip address (both public ip and private ip), cannot ssh to droplet, droplet cannot connect to internet or private ip, the only way I can access my droplet is from web console

https://prnt.sc/w9gso9

what should i do?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @superditif,

It seems to me like you’ve made some network conflict. Try using the command

ip addr

On your droplet to see if you still have your IP address added as linked there. If you can see it in the information, you can try and restart your network service like so

service network restart

If it doesn’t work, I’ll suggest contacting DigitalOcean’s support for their help. They should be able to assist you with the issue. You can reach them on the following link:

https://www.digitalocean.com/support/

Regards,
KFSys

  • hello KFSys, thanks for the response, yes I already tried network restart even reboot several times, but it still not work, I just end up by creating droplet snapshot, and recreate droplet from that snapshot

    • Hi @superditif,

      I see, thank you for the clarification.

      In such cases where you have network issues, I’ll recommend contacting DigitalOcean’s support. They’ll help you fix them, that is in case you need it in the future!

Submit an Answer