Question

Droplet not working with custom domain.

I need my wordpress website to be accessible via https from the origin server. Previously it was being accesed via http by CloudFlare but now I’m stopping CloudFlare and want to serve directly from the droplet with https.

I’ve registered a domain with NameCheap. Pointed the nameservers to DO. Added the domain in DO. Added an A record pointing to the droplet. Added a DO created ssl certificate.

But the website is inaccessible, and if attempts are made to access via the ip address or using http it 301s to the https version for an unknown reason.

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I had a similar issue and resolved it with advice in this thread

https://meta.discourse.org/t/discourse-version-at-forum-abc-com-au-not-found/124016/4

For me it was the resolution of the ssl certificate in the CAA record

Hello, @oliver8bbb098206659bed868e

What I could suggest is to use certbot to issue and install your Let’s Encrypt SSL certificate.

If you are using Apache as your web server, you could follow this step by step tutorial here on how to do that:

https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04

If you are using Nginx, you could follow the steps here:

https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-18-04

Once installed you will have the option to set all the needed redirection.

Hope that this helps!

Regards, Alex