ELIOT84
By:
ELIOT84

Droplets not working with Vagrant DigitalOcean Tutorial.. VBoxManage not installing

October 27, 2014 2k views

Hi Everyone,

I have been struggling with using Vagrant/Virtualbox on my droplets and was hoping someone might know what is going on. Tried to replicate the tutorial from Digital Ocean for using Vagrant but I'm running into an error where VBoxManage is not installing correctly. I am adding the code below from when I re-created a new droplet ubuntu 64bit 1gb and performed the steps in the tutorial again. The tutorial followed was:

https://www.digitalocean.com/community/tutorials/how-to-install-vagrant-on-a-vps-running-ubuntu-12-04

The output of that code is in section 2 below

SECTION 1
SECTION 1
SECTION 1

root@eliot84:~# vboxmanage --version 
The program 'vboxmanage' is currently not installed. You can install it by typing: 
apt-get install virtualbox 
root@eliot84:~# apt-get install virtualbox 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
The following extra packages will be installed: 
binutils cpp cpp-4.6 dkms fakeroot fontconfig fontconfig-config gcc gcc-4.6 
libasound2 libasyncns0 libaudio2 libavahi-client3 libavahi-common-data 
libavahi-common3 libc-dev-bin libc6-dev libcaca0 libcups2 libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libtiff4 libvncserver0 
libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 libxdamage1 
libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 libxxf86vm1 
linux-libc-dev make manpages-dev mysql-common python-central qdbus 
ttf-dejavu-core virtualbox-dkms virtualbox-qt x11-common 
Suggested packages: 
binutils-doc cpp-doc gcc-4.6-locales gcc-multilib autoconf automake1.9 
libtool flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev 
gcc-4.6-doc libgcc1-dbg libgomp1-dbg libquadmath0-dbg libmudflap0-dbg 
binutils-gold libasound2-plugins libasound2-python nas glibc-doc cups-common 
libglide3 liblcms-utils pulseaudio libqt4-declarative-folderlistmodel 
libqt4-declarative-gestures libqt4-declarative-particles 
libqt4-declarative-shaders qt4-qmlviewer libqt4-dev libthai0 qt4-qtconfig 
libvncserver0-dbg make-doc virtualbox-guest-additions-iso vde2 
The following NEW packages will be installed: 
binutils cpp cpp-4.6 dkms fakeroot fontconfig fontconfig-config gcc gcc-4.6 
libasound2 libasyncns0 libaudio2 libavahi-client3 libavahi-common-data 
libavahi-common3 libc-dev-bin libc6-dev libcaca0 libcups2 libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libtiff4 libvncserver0 
libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 libxdamage1 
libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 libxxf86vm1 
linux-libc-dev make manpages-dev mysql-common python-central qdbus 
ttf-dejavu-core virtualbox virtualbox-dkms virtualbox-qt x11-common 
0 upgraded, 79 newly installed, 0 to remove and 0 not upgraded. 
Need to get 1,821 kB/71.6 MB of archives. 
After this operation, 226 MB of additional disk space will be used. 
Do you want to continue [Y/n]? y 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main mysql-common all 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main libmysqlclient18 amd64 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main linux-libc-dev amd64 3.2.0-69.103 
404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.38-0ubuntu0.12.04.1_all.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.38-0ubuntu0.12.04.1_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.2.0-69.103_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? 
root@eliot84:~# vboxmanage --version 
The program 'vboxmanage' is currently not installed. You can install it by typing: 
apt-get install virtualbox 
root@eliot84:~#

SECTION 2
SECTION 2
SECTION 2

Welcome to Ubuntu 12.04.5 LTS (GNU/Linux 3.13.0-32-generic x86_64)

* Documentation: https://help.ubuntu.com/

System information as of Fri Oct 24 19:53:26 EDT 2014

System load: 0.0 Processes: 67 
Usage of /: 7.0% of 29.40GB Users logged in: 0 
Memory usage: 5% IP address for eth0: 104.131.20.187 
Swap usage: 0%

Graph this data and manage this system at: 
https://landscape.canonical.com/

New release '14.04.1 LTS' available. 
Run 'do-release-upgrade' to upgrade to it.

Your Hardware Enablement Stack (HWE) is supported until April 2017.

Changing password for root. 
(current) UNIX password: 
Enter new UNIX password: 
Retype new UNIX password: 
root@eliotdev:~# cd .. 
root@eliotdev:/# ls 
bin home lib64 opt sbin tmp vmlinuz.old 
boot initrd.img lost+found proc selinux usr 
dev initrd.img.old media root srv var 
etc lib mnt run sys vmlinuz 
root@eliotdev:/# sudo apt-get install dpkg-dev virtualbox-dkms 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
The following extra packages will be installed: 
binutils build-essential cpp cpp-4.6 dkms fakeroot fontconfig 
fontconfig-config g++ g++-4.6 gcc gcc-4.6 libalgorithm-diff-perl 
libalgorithm-diff-xs-perl libalgorithm-merge-perl libasound2 libasyncns0 
libaudio2 libavahi-client3 libavahi-common-data libavahi-common3 
libc-dev-bin libc6-dev libcaca0 libcups2 libdpkg-perl libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libstdc++6-4.6-dev libtiff4 
libvncserver0 libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 
libxdamage1 libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 
libxxf86vm1 linux-libc-dev make manpages-dev mysql-common python-central 
qdbus ttf-dejavu-core virtualbox virtualbox-qt x11-common 
Suggested packages: 
binutils-doc cpp-doc gcc-4.6-locales debian-keyring g++-multilib 
g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg gcc-multilib autoconf 
automake1.9 libtool flex bison gdb gcc-doc gcc-4.6-multilib 
libmudflap0-4.6-dev libgcc1-dbg libgomp1-dbg libquadmath0-dbg 
libmudflap0-dbg binutils-gold libasound2-plugins libasound2-python nas 
glibc-doc cups-common libglide3 liblcms-utils pulseaudio 
libqt4-declarative-folderlistmodel libqt4-declarative-gestures 
libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer 
libqt4-dev libthai0 qt4-qtconfig libstdc++6-4.6-doc libvncserver0-dbg 
make-doc virtualbox-guest-additions-iso vde2 
The following NEW packages will be installed: 
binutils build-essential cpp cpp-4.6 dkms dpkg-dev fakeroot fontconfig 
fontconfig-config g++ g++-4.6 gcc gcc-4.6 libalgorithm-diff-perl 
libalgorithm-diff-xs-perl libalgorithm-merge-perl libasound2 libasyncns0 
libaudio2 libavahi-client3 libavahi-common-data libavahi-common3 
libc-dev-bin libc6-dev libcaca0 libcups2 libdpkg-perl libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libstdc++6-4.6-dev libtiff4 
libvncserver0 libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 
libxdamage1 libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 
libxxf86vm1 linux-libc-dev make manpages-dev mysql-common python-central 
qdbus ttf-dejavu-core virtualbox virtualbox-dkms virtualbox-qt x11-common 
0 upgraded, 88 newly installed, 0 to remove and 0 not upgraded. 
Need to get 81.0 MB of archives. 
After this operation, 254 MB of additional disk space will be used. 
Do you want to continue [Y/n]? y 
Get:1 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libasound2 amd64 1.0.25-1ubuntu10.2 [428 kB] 
Get:2 http://mirrors.digitalocean.com/ubuntu/ precise/main libasyncns0 amd64 0.8-4 [13.2 kB] 
Get:3 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main x11-common all 1:7.6+12ubuntu2 [52.0 kB] 
Get:4 http://mirrors.digitalocean.com/ubuntu/ precise/main libice6 amd64 2:1.0.7-2build1 [46.1 kB] 
Get:5 http://mirrors.digitalocean.com/ubuntu/ precise/main libsm6 amd64 2:1.2.0-2build1 [18.1 kB] 
Get:6 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxt6 amd64 1:1.1.1-2ubuntu0.1 [186 kB] 
Get:7 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libaudio2 amd64 1.9.3-4ubuntu0.1 [57.1 kB] 
Get:8 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libavahi-common-data amd64 0.6.30-5ubuntu2.1 [21.4 kB] 
Get:9 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libavahi-common3 amd64 0.6.30-5ubuntu2.1 [25.5 kB] 
Get:10 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libavahi-client3 amd64 0.6.30-5ubuntu2.1 [30.3 kB] 
Get:11 http://mirrors.digitalocean.com/ubuntu/ precise/main libcaca0 amd64 0.99.beta17-2.1ubuntu2 [246 kB] 
Get:12 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libcups2 amd64 1.5.3-0ubuntu8.5 [168 kB] 
Get:13 http://mirrors.digitalocean.com/ubuntu/ precise/main libogg0 amd64 1.2.2~dfsg-1ubuntu1 [17.2 kB] 
Get:14 http://mirrors.digitalocean.com/ubuntu/ precise/main libflac8 amd64 1.2.1-6 [144 kB] 
Get:15 http://mirrors.digitalocean.com/ubuntu/ precise/main ttf-dejavu-core all 2.33-2ubuntu1 [1,552 kB] 
Get:16 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main fontconfig-config all 2.8.0-3ubuntu9.1 [44.4 kB] 
Get:17 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libfontconfig1 amd64 2.8.0-3ubuntu9.1 [125 kB] 
Get:18 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libglapi-mesa amd64 8.0.4-0ubuntu0.7 [21.3 kB] 
Get:19 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libx11-xcb1 amd64 2:1.4.99.1-0ubuntu2.2 [10.5 kB] 
Get:20 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxcb-glx0 amd64 1.8.1-1ubuntu0.2 [26.4 kB] 
Get:21 http://mirrors.digitalocean.com/ubuntu/ precise/main libxdamage1 amd64 1:1.1.3-2build1 [7,560 B] 
Get:22 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxfixes3 amd64 1:5.0-4ubuntu4.2 [12.5 kB] 
Get:23 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxxf86vm1 amd64 1:1.1.1-2ubuntu0.1 [11.9 kB] 
Get:24 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libgl1-mesa-glx amd64 8.0.4-0ubuntu0.7 [104 kB] 
Get:25 http://mirrors.digitalocean.com/ubuntu/ precise/main libgomp1 amd64 4.6.3-1ubuntu5 [25.5 kB] 
Get:26 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libjpeg-turbo8 amd64 1.1.90+svn733-0ubuntu4.4 [112 kB] 
Get:27 http://mirrors.digitalocean.com/ubuntu/ precise/main liblcms1 amd64 1.19.dfsg-1ubuntu3 [106 kB] 
Get:28 http://mirrors.digitalocean.com/ubuntu/ precise/main libllvm3.0 amd64 3.0-4ubuntu1 [7,456 kB] 
Get:29 http://mirrors.digitalocean.com/ubuntu/ precise/main libjpeg8 amd64 8c-2ubuntu7 [2,112 B] 
Get:30 http://mirrors.digitalocean.com/ubuntu/ precise/main libmng1 amd64 1.0.10-3 [215 kB] 
Get:31 http://mirrors.digitalocean.com/ubuntu/ precise/main libmpfr4 amd64 3.1.0-3ubuntu2 [201 kB] 
Get:32 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libjson0 amd64 0.9-1ubuntu1.1 [17.9 kB] 
Get:33 http://mirrors.digitalocean.com/ubuntu/ precise/main libvorbis0a amd64 1.3.2-1ubuntu3 [103 kB] 
Get:34 http://mirrors.digitalocean.com/ubuntu/ precise/main libvorbisenc2 amd64 1.3.2-1ubuntu3 [136 kB] 
Get:35 http://mirrors.digitalocean.com/ubuntu/ precise/main libsndfile1 amd64 1.0.25-4 [163 kB] 
Get:36 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libpulse0 amd64 1:1.1-0ubuntu15.4 [289 kB] 
Get:37 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqtcore4 amd64 4:4.8.1-0ubuntu4.8 [2,027 kB] 
Get:38 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-xml amd64 4:4.8.1-0ubuntu4.8 [95.1 kB] 
Get:39 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-dbus amd64 4:4.8.1-0ubuntu4.8 [179 kB] 
Get:40 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-network amd64 4:4.8.1-0ubuntu4.8 [535 kB] 
Get:41 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-script amd64 4:4.8.1-0ubuntu4.8 [758 kB] 
Get:42 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-sql amd64 4:4.8.1-0ubuntu4.8 [97.0 kB] 
Get:43 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-xmlpatterns amd64 4:4.8.1-0ubuntu4.8 [1,033 kB] 
Get:44 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main fontconfig amd64 2.8.0-3ubuntu9.1 [156 kB] 
Get:45 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libtiff4 amd64 3.9.5-2ubuntu1.6 [144 kB] 
Get:46 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxi6 amd64 2:1.7.1.901-1ubuntu1~precise1 [31.6 kB] 
Get:47 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxrender1 amd64 1:0.9.6-2ubuntu0.1 [20.6 kB] 
Get:48 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqtgui4 amd64 4:4.8.1-0ubuntu4.8 [4,027 kB] 
Get:49 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-declarative amd64 4:4.8.1-0ubuntu4.8 [1,064 kB] 
Get:50 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-opengl amd64 4:4.8.1-0ubuntu4.8 [293 kB] 
Get:51 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libqt4-sql-mysql amd64 4:4.8.1-0ubuntu4.8 [30.0 kB] 
Get:52 http://mirrors.digitalocean.com/ubuntu/ precise/main libquadmath0 amd64 4.6.3-1ubuntu5 [126 kB] 
Get:53 http://mirrors.digitalocean.com/ubuntu/ precise/main libsdl1.2debian amd64 1.2.14-6.4ubuntu3 [197 kB] 
Get:54 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxcursor1 amd64 1:1.1.12-1ubuntu0.1 [22.7 kB] 
Get:55 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libxinerama1 amd64 2:1.1.1-3ubuntu0.1 [8,072 B] 
Get:56 http://mirrors.digitalocean.com/ubuntu/ precise/main libxmu6 amd64 2:1.1.0-3 [52.7 kB] 
Get:57 http://mirrors.digitalocean.com/ubuntu/ precise/main libmpc2 amd64 0.9-4 [39.5 kB] 
Get:58 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main binutils amd64 2.22-6ubuntu1.1 [2,638 kB] 
Get:59 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libc-dev-bin amd64 2.15-0ubuntu10.7 [83.9 kB] 
Get:60 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libc6-dev amd64 2.15-0ubuntu10.7 [2,941 kB] 
Get:61 http://mirrors.digitalocean.com/ubuntu/ precise/main cpp-4.6 amd64 4.6.3-1ubuntu5 [4,836 kB] 
Get:62 http://mirrors.digitalocean.com/ubuntu/ precise/main cpp amd64 4:4.6.3-1ubuntu5 [27.6 kB] 
Get:63 http://mirrors.digitalocean.com/ubuntu/ precise/main gcc-4.6 amd64 4.6.3-1ubuntu5 [7,572 kB] 
Get:64 http://mirrors.digitalocean.com/ubuntu/ precise/main gcc amd64 4:4.6.3-1ubuntu5 [5,114 B] 
Get:65 http://mirrors.digitalocean.com/ubuntu/ precise/main libstdc++6-4.6-dev amd64 4.6.3-1ubuntu5 [1,660 kB] 
Get:66 http://mirrors.digitalocean.com/ubuntu/ precise/main g++-4.6 amd64 4.6.3-1ubuntu5 [6,954 kB] 
Get:67 http://mirrors.digitalocean.com/ubuntu/ precise/main g++ amd64 4:4.6.3-1ubuntu5 [1,442 B] 
Get:68 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main make amd64 3.81-8.1ubuntu1.1 [119 kB] 
Get:69 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libdpkg-perl all 1.16.1.2ubuntu7.5 [182 kB] 
Get:70 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main dpkg-dev all 1.16.1.2ubuntu7.5 [468 kB] 
Get:71 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main build-essential amd64 11.5ubuntu2.1 [5,816 B] 
Get:72 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main dkms all 2.2.0.3-1ubuntu3.2 [72.6 kB] 
Get:73 http://mirrors.digitalocean.com/ubuntu/ precise/main fakeroot amd64 1.18.2-1 [87.2 kB] 
Get:74 http://mirrors.digitalocean.com/ubuntu/ precise/main libalgorithm-diff-perl all 1.19.02-2 [50.7 kB] 
Get:75 http://mirrors.digitalocean.com/ubuntu/ precise/main libalgorithm-diff-xs-perl amd64 0.04-2build2 [12.4 kB] 
Get:76 http://mirrors.digitalocean.com/ubuntu/ precise/main libalgorithm-merge-perl all 0.08-2 [12.7 kB] 
Get:77 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main libgl1-mesa-dri amd64 8.0.4-0ubuntu0.7 [3,035 kB] 
Get:78 http://mirrors.digitalocean.com/ubuntu/ precise/universe libgsoap1 amd64 2.8.4-2 [507 kB] 
Get:79 http://mirrors.digitalocean.com/ubuntu/ precise/main libvncserver0 amd64 0.9.8.2-2ubuntu1 [186 kB] 
Get:80 http://mirrors.digitalocean.com/ubuntu/ precise/main manpages-dev all 3.35-0.1ubuntu1 [1,671 kB] 
Get:81 http://mirrors.digitalocean.com/ubuntu/ precise-updates/universe python-central all 0.6.17ubuntu2 [41.4 kB] 
Get:82 http://mirrors.digitalocean.com/ubuntu/ precise-updates/main qdbus amd64 4:4.8.1-0ubuntu4.8 [28.6 kB] 
Get:83 http://mirrors.digitalocean.com/ubuntu/ precise-updates/universe virtualbox amd64 4.1.12-dfsg-2ubuntu0.6 [15.6 MB] 
Get:84 http://mirrors.digitalocean.com/ubuntu/ precise-updates/universe virtualbox-dkms all 4.1.12-dfsg-2ubuntu0.6 [677 kB] 
Get:85 http://mirrors.digitalocean.com/ubuntu/ precise-updates/universe virtualbox-qt amd64 4.1.12-dfsg-2ubuntu0.6 [6,490 kB] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main mysql-common all 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main libmysqlclient18 amd64 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main linux-libc-dev amd64 3.2.0-69.103 
404 Not Found [IP: 192.241.164.26 80] 
Fetched 79.1 MB in 4s (18.7 MB/s) 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.38-0ubuntu0.12.04.1_all.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.38-0ubuntu0.12.04.1_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.2.0-69.103_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? 
root@eliotdev:/# wget http://files.vagrantup.com/packages/0219bb87725aac28a97c0e924c310cc97831fd9d/vagrant_1.2.4_i686.deb
--2014-10-24 19:55:29-- http://files.vagrantup.com/packages/0219bb87725aac28a97c0e924c310cc97831fd9d/vagrant_1.2.4_i686.deb
Resolving files.vagrantup.com (files.vagrantup.com)... 54.235.223.108 
Connecting to files.vagrantup.com (files.vagrantup.com)|54.235.223.108|:80... connected. 
HTTP request sent, awaiting response... 302 Found 
Location: http://hashicorp-files.vagrantup.com/packages/0219bb87725aac28a97c0e924c310cc97831fd9d/vagrant_1.2.4_i686.deb [following] 
--2014-10-24 19:55:29-- http://hashicorp-files.vagrantup.com/packages/0219bb87725aac28a97c0e924c310cc97831fd9d/vagrant_1.2.4_i686.deb
Resolving hashicorp-files.vagrantup.com (hashicorp-files.vagrantup.com)... 107.170.61.177 
Connecting to hashicorp-files.vagrantup.com (hashicorp-files.vagrantup.com)|107.170.61.177|:80... connected. 
HTTP request sent, awaiting response... 200 OK 
Length: 19470998 (19M) [application/x-debian-package] 
Saving to: `vagrant_1.2.4_i686.deb'

100%[======================================>] 19,470,998 61.9M/s in 0.3s

2014-10-24 19:55:30 (61.9 MB/s) - `vagrant_1.2.4_i686.deb' saved [19470998/19470998]

root@eliotdev:/# dpkg -i vagrant_1.2.4_i686.deb 
Selecting previously unselected package vagrant:i386. 
(Reading database ... 139056 files and directories currently installed.) 
Unpacking vagrant:i386 (from vagrant_1.2.4_i686.deb) ... 
Setting up vagrant:i386 (1.2.4) ... 
root@eliotdev:/# sudo apt-get install linux-headers-$(uname -r) 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
linux-headers-3.13.0-32-generic is already the newest version. 
linux-headers-3.13.0-32-generic set to manually installed. 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 
root@eliotdev:/# sudo dpkg-reconfigure virtualbox-dkms 
Package `virtualbox-dkms' is not installed and no info is available. 
Use dpkg --info (= dpkg-deb --info) to examine archive files, 
and dpkg --contents (= dpkg-deb --contents) to list their contents. 
/usr/sbin/dpkg-reconfigure: virtualbox-dkms is not installed 
root@eliotdev:/# vagrant box add precise32 http://files.vagrantup.com/precise32.box 
/opt/vagrant/bin/vagrant: line 91: /opt/vagrant/bin/../embedded/bin/ruby: No such file or directory 
root@eliotdev:/# vagrant 
/opt/vagrant/bin/vagrant: line 91: /opt/vagrant/bin/../embedded/bin/ruby: No such file or directory 
root@eliotdev:/# ls 
bin initrd.img media run tmp vmlinuz.old 
boot initrd.img.old mnt sbin usr 
dev lib opt selinux vagrant_1.2.4_i686.deb 
etc lib64 proc srv var 
home lost+found root sys vmlinuz 
root@eliotdev:/# VBoxManage 
The program 'VBoxManage' is currently not installed. You can install it by typing: 
apt-get install virtualbox 
root@eliotdev:/# apt-get install virtualbox 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
The following extra packages will be installed: 
binutils cpp cpp-4.6 dkms fakeroot fontconfig fontconfig-config gcc gcc-4.6 
libasound2 libasyncns0 libaudio2 libavahi-client3 libavahi-common-data 
libavahi-common3 libc-dev-bin libc6-dev libcaca0 libcups2 libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libtiff4 libvncserver0 
libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 libxdamage1 
libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 libxxf86vm1 
linux-libc-dev make manpages-dev mysql-common python-central qdbus 
ttf-dejavu-core virtualbox-dkms virtualbox-qt x11-common 
Suggested packages: 
binutils-doc cpp-doc gcc-4.6-locales gcc-multilib autoconf automake1.9 
libtool flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev 
gcc-4.6-doc libgcc1-dbg libgomp1-dbg libquadmath0-dbg libmudflap0-dbg 
binutils-gold libasound2-plugins libasound2-python nas glibc-doc cups-common 
libglide3 liblcms-utils pulseaudio libqt4-declarative-folderlistmodel 
libqt4-declarative-gestures libqt4-declarative-particles 
libqt4-declarative-shaders qt4-qmlviewer libqt4-dev libthai0 qt4-qtconfig 
libvncserver0-dbg make-doc virtualbox-guest-additions-iso vde2 
The following NEW packages will be installed: 
binutils cpp cpp-4.6 dkms fakeroot fontconfig fontconfig-config gcc gcc-4.6 
libasound2 libasyncns0 libaudio2 libavahi-client3 libavahi-common-data 
libavahi-common3 libc-dev-bin libc6-dev libcaca0 libcups2 libflac8 
libfontconfig1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgomp1 
libgsoap1 libice6 libjpeg-turbo8 libjpeg8 libjson0 liblcms1 libllvm3.0 
libmng1 libmpc2 libmpfr4 libmysqlclient18 libogg0 libpulse0 libqt4-dbus 
libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql 
libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 
libquadmath0 libsdl1.2debian libsm6 libsndfile1 libtiff4 libvncserver0 
libvorbis0a libvorbisenc2 libx11-xcb1 libxcb-glx0 libxcursor1 libxdamage1 
libxfixes3 libxi6 libxinerama1 libxmu6 libxrender1 libxt6 libxxf86vm1 
linux-libc-dev make manpages-dev mysql-common python-central qdbus 
ttf-dejavu-core virtualbox virtualbox-dkms virtualbox-qt x11-common 
0 upgraded, 79 newly installed, 0 to remove and 0 not upgraded. 
Need to get 1,821 kB/71.6 MB of archives. 
After this operation, 226 MB of additional disk space will be used. 
Do you want to continue [Y/n]? y 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main mysql-common all 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main libmysqlclient18 amd64 5.5.38-0ubuntu0.12.04.1 
404 Not Found [IP: 192.241.164.26 80] 
Err http://mirrors.digitalocean.com/ubuntu/ precise-security/main linux-libc-dev amd64 3.2.0-69.103 
404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.38-0ubuntu0.12.04.1_all.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.38-0ubuntu0.12.04.1_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/l/linux/linux-libc-dev_3.2.0-69.103_amd64.deb 404 Not Found [IP: 192.241.164.26 80] 
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? 
root@eliotdev:/# ls 
bin initrd.img media run tmp vmlinuz.old 
boot initrd.img.old mnt sbin usr 
dev lib opt selinux vagrant_1.2.4_i686.deb 
etc lib64 proc srv var 
home lost+found root sys vmlinuz 
root@eliotdev:/# VBoxManage 
The program 'VBoxManage' is currently not installed. You can install it by typing: 
apt-get install virtualbox
1 Answer

Hi,

From those error messages, it looks like you probably just need to update the package cache by running apt-get update

I always suggest running:

apt-get update
apt-get upgrade

as one of the first things you do when you spin up a new server. That way you update the package cache and install any available security upgrades.

Have another answer? Share your knowledge.