Drupal authentication disappered

  • Posted February 1, 2014


I just migrate a working Drupal7 installation from my old server to my new droplet (Ubuntu 12.4). After some trouble with the mysql configuration, which have been solved very quickly thanks to a prompt and plain support, I still have a problem with the authentication system. Unexpectedly, nothing happens by inserting drupal login-information. I can’t either access to the administration area, nor get an error. The website was obviously working on the previous server.

Does anybody had similar experiences with Drupal? Or some suggestions about how to troubleshoot this?


This comment has been deleted

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Thank you very much! I solved with mod_rewrite. In fact the website uses clean urls. Best.

Make sure mod_rewrite is enabled. (a2enmod rewrite && service apache2 restart) <br>Make sure that AllowOverride is set properly for your Drupal directory. (Edit /etc/apache2/sites-enabled/000-default or equivalent. AllowOverride All will work for testing.) <br>Clear your caches and such. (apt-get install drush && drush cc all) <br> <br>If that doesn’t work post your logs from /var/log/apache2/.