Drush on centos

  • Posted April 29, 2014

I have a problem with drush. I have install vestacp, after the composer globally and then i require via composer drush/drush:dev-master.

The drush download successfull the drupal and install it with site-install command but when i use drush for enable or upwd return: Command user-password needs a higher bootstrap level to run - you [error] will need to invoke drush from a more functional Drupal environment to run this command. The drush command ‘upwd admin’ could not be executed. [error] Drush was not able to start (bootstrap) the Drupal database. [error] Hint: This may occur when Drush is trying to:

  • bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See drush topic docs-aliases for details.
  • connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See for details.

Drush was attempting to connect to: Drupal version : 7.26 Site URI : http://default Database driver : mysql Database username : admin_drupal Database name : admin_sitedb PHP executable : /usr/bin/php PHP configuration : /etc/php.ini PHP OS : Linux Drush version : 7.0-dev Drush temp directory : /tmp Drush configuration : Drush alias files : Drupal root : /home/admin/web/mydomain/public_html/ site Site path : sites/default

I try the solution of the link but nothing. Any ideas? I use centos 6.4 x64 + VestaCP the composer is ok.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Are you running the drush command from inside the directory containing your drupal site? It seems like it can’t find your settings.php file. See: <br> <br>