drush sql-sync

Posted October 21, 2013 5.1k views
Hi guys! I'm trying to synchronize my database with the commad "drush sql-sync" but apparently I have not improperly set permissions somewhere that tells me the following error. ================================== mv: cannot move `/tmp/name-db.sql-1382384285' to `/tmp/name-db.sql': Operation not permitted Database dump failed ================================== They know how I can solve it? Best regards!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
6 answers
Make sure that your mysql user has the following permissions. This will allow it to lock all of the databases required in the sync.

grant all privileges on your_db.* to your_username@localhost with grant option;
grant reload on *.* to druser2@localhost;
flush privileges;

Let me know if you have issues after doing those steps :)
See if what Etel posted fixes it. If not, what's the output of stat /tmp?
Hello Etel!

Thank you for your help!
I followed the steps you indicated, but still without being able to connect.

This is the message:

Connection Failed
Host '' is not allowed to connect to this MySQL server

How to enable/disable MySQL remote access?

Best regards!

@cfranco80: Since you're not running that command locally, you will have to allow your IP address to connect to the MySQL server.

Simply run Etel's commands again replacing 'localhost' with your IP address.

Let me know if that works. :]
Hi Kamal Nasser!

thank you for your response. I am new in VPS manage and I buyed this VPS to learning.

What is Etel´s commands and how to work?

Best regards!
@cfranco80: Etel's commands are the commands she posted above on October 21st, 2013 22:37: