Question

drush sql-sync

  • Posted October 21, 2013

Hi guys!

I’m trying to synchronize my database with the commad “drush sql-sync” but apparently I have not improperly set permissions somewhere that tells me the following error.

================================== mv: cannot move /tmp/name-db.sql-1382384285' to /tmp/name-db.sql’: Operation not permitted Database dump failed

They know how I can solve it?

Best regards!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@cfranco80: Etel’s commands are the commands she posted above on October 21st, 2013 22:37: <br> <br><img src=“https://kmlnsr.me/Screenshot from 2013-10-30 15%3A20%3A17.png” />

Hi Kamal Nasser! <br> <br>thank you for your response. I am new in VPS manage and I buyed this VPS to learning.
<br> <br>What is Etel´s commands and how to work? <br> <br>Best regards! <br>

@cfranco80: Since you’re not running that command locally, you will have to allow your IP address to connect to the MySQL server. <br> <br>Simply run Etel’s commands again replacing ‘localhost’ with your IP address. <br> <br>Let me know if that works. :]

Hello Etel! <br> <br>Thank you for your help! <br>I followed the steps you indicated, but still without being able to connect. <br> <br>This is the message: <br> <br>Connection Failed <br>Host ‘my.ip.work.station.static.axtel.net’ is not allowed to connect to this MySQL server <br> <br>How to enable/disable MySQL remote access? <br> <br>Best regards! <br> <br>

See if what Etel posted fixes it. If not, what’s the output of <code>stat /tmp</code>?

Make sure that your mysql user has the following permissions. This will allow it to lock all of the databases required in the sync. <br> <br>grant all privileges on your_db.* to your_username@localhost with grant option; <br>grant reload on . to druser2@localhost; <br>flush privileges; <br> <br>Let me know if you have issues after doing those steps :)