Question

ElasticSearch S3 repository Snapshot to Spaces fails

I have installed ElasticSearch 6.2 on a droplet running ubuntu 16.04 and what to create a s3 repository that backup my ElasticSearch database to a space though the S3 Spaces API. For some reason, I keep getting the same error every time, I try to create my repository:

{"error":{
     "root_cause":[{
          "type":"blob_store_exception",
          "reason":"Failed to check if blob [master.dat-temp] exists"}],
     "type":"blob_store_exception",
     "reason":"Failed to check if blob [master.dat-temp] exists",
     "caused_by":{
          "type":"amazon_s3_exception",
          "reason":"Forbidden (
               Service: Amazon S3;
               Status Code: 403;
               Error Code: 403 Forbidden;
               Request ID: THEREQUESTID;
               S3 Extended Request ID: THEEXTENDEDREQUESTID)"}},
"status":500}

I might add, that I also have a droplet running with ElasticSearch 5.6 and on that droplet, there is no problem creating s3 repositories and backing up my data to Spaces.

What I’m I missing?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi emily,

got it solved? Care to share your solution? I would also be interested in your configuration of the plugin.

Kind regards,

Stefan

Did anyone solve this issue? I ran into exact same problem.