Question

Email not received at Google Apps

Posted November 12, 2014 3.4k views

Hello,
I’m testing to send an email with “echo test | mail myemail@gmail.com” and I can receive the email.
But not to my google apps email (echo test | mail myemail@xxxx.com).
I dont receive that email (already checked the spam folder as well).
There should not be any issue with the DNS I believe as I can send/receive the Google apps email as usual from external source.

I’m asking this because the Contact Form 7 in my website doesnt work. When I changed to my personal gmail I do receive it. So I come down to this testing process and that’s what I encountered.

Here’s my DNS zone file
$ORIGIN xxxxxx.com.
$TTL 1800
xxxxxx.com. IN SOA ns1.digitalocean.com. hostmaster.xxxxxx.com. 1415421753 10800 3600 604800 1800
xxxxxx.com. 1800 IN A 128.199.149.199
xxxxxx.com. 1800 IN NS ns1.digitalocean.com.
xxxxxx.com. 1800 IN NS ns2.digitalocean.com.
xxxxxx.com. 1800 IN NS ns3.digitalocean.com.
www.xxxxxx.com. 1800 IN A 128.199.149.199
xxxxxx.com. 1800 IN MX 1 aspmx.l.google.com.
xxxxxx.com. 1800 IN MX 5 alt1.aspmx.l.google.com.
xxxxxx.com. 1800 IN MX 5 alt2.aspmx.l.google.com.
xxxxxx.com. 1800 IN MX 10 aspmx2.googlemail.com.
xxxxxx.com. 1800 IN MX 10 aspmx3.googlemail.com.

Why can’t I receive email in my Google Apps here?
Thanks for any help.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Are you using sendmail?

I have the same problem before, if your droplet’s hostname is the same as the receiving domain.

sendmail will deliver the mail locally.

You may verify that by checking /var/mail/<myemail>.

You can follow this post to disable sendmail’s local delivery.

http://serverfault.com/questions/65365/disable-local-delivery-in-sendmail

Submit an Answer