Hello everyone, i’m having an issue. I’m new in DO and i don’t know how much days they need to reply a ticket. I’ve installed plesk on my droplet and tried to configure domain’s email. I can receive mails but i can’t send It.

Plesk says me that I’ve the TCP 25 PORT closed but with netstat i can see that it’s open.

No DO’s firewall Is configured so there aren’t conflicts.

Dovecot Is running perfectly.

When i try this :

telnet alt2.gmail-smtp-in.l.google.com 25

The response Is :

telnet: Unable to connect to remote host: Network is unreachable

No idea of what to do and how to solve. Maybe DO blocks ports ? But why with netstat i can see them open?

Thanks to all

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @KyrosWeb,

I believe that for new accounts outgoing TCP connections on port 25 are blocked for security reasons.

I would recommend trying with port 587 or 465 instead.

Let me know how it goes!
Regards,
Bobby

  • Thanks for reply , i can’t find the section to enable the 465 port and online i can’t find nothing. Can you help me ?

    • Hi there @KyrosWeb,

      I would suggest first testing if port 465 is open for outgoing TCP connections. One way to do that is to run the following command:

      • telnet portquiz.net 465

      If this does not work, I would recommend sticking with port 587, you can take a look at the official documentation here on how to enable port 587:

      https://support.plesk.com/hc/en-us/articles/213372829

      Go to Plesk > Tools & Settings > Mail Server Settings set the Enable SMTP service on port 587 on all IP addresses checkbox.

      Let me know if that works.
      Regards,
      Bobby

      • Ho Bobby , thanks for t ply. I tried yet to enable SMTP service on 587 but it doesn’t work.

        • Hello,

          Does the telnet command work for port 587:

          • telnet portquiz.net 587

          Also with netstat can you see port 587 as well?

          • netstat -plant | grep 587

          Regards,
          Bobby

          • Hi Bobby a paste here what i see

            with telnet :

            Connected to portquiz.net.
            Escape character is ’^]’.
            Connection closed by foreign host.

            with netstat:

            tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 30647/master

            tcp 0 0 10.10.0.5:443 34.243.12.29:58756 ESTABLISHED 6529/nginx: worker

            tcp6 0 0 :::587 :::* LISTEN 30647/master

            Thanks a lot for helping

          • Hi there @KyrosWeb,

            It actually looks all good. Are you seeing any errors in your mail log?

            Regards,
            Bobby

      • Thanks Bobby i’ve pointed DNS to another hosting where i can manage mails. On DO i haven’t received reply in support ticket so i think there is no solution.

        Regards and thanks for helping.

Submit an Answer