Question

Email unable to send, but can receive

Got some issue with my newly setup droplet. Looks like I can’t send any email to any address. Below is one of the testing I’ve made.

This is the mail system at host vps.paskal.my.

####################################################################
# THIS IS A WARNING ONLY.  YOU DO NOT NEED TO RESEND YOUR MESSAGE. #
####################################################################

Your message could not be delivered for more than 4 hour(s).
It will be retried until it is 5 day(s) old.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<mizi@iwhost.com>: connect to iwhost.com[103.8.24.2]:25: Connection timed out
Reporting-MTA: dns; vps.paskal.my
X-Postfix-Queue-ID: 8BDB3BDC46
X-Postfix-Sender: rfc822; root@paskal.my
Arrival-Date: Fri, 14 Aug 2020 02:36:26 +0000 (UTC)

Final-Recipient: rfc822; mizi@iwhost.com
Original-Recipient: rfc822;mizi@iwhost.com
Action: delayed
Status: 4.4.1
Diagnostic-Code: X-Postfix; connect to iwhost.com[103.8.24.2]:25: Connection
    timed out
Will-Retry-Until: Wed, 19 Aug 2020 02:36:26 +0000 (UTC)
Return-Path: <root@paskal.my>
Received: from [192.168.0.5] (unknown [121.122.54.45])
    (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
    (No client certificate requested)
    by vps.paskal.my (Postfix) with ESMTPSA id 8BDB3BDC46
    for <mizi@iwhost.com>; Fri, 14 Aug 2020 02:36:26 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=paskal.my; s=default;
    t=1597372586; bh=HhLK9q5QULlFvFacW/fWBx6Fd98MKgtH340pDFpadv8=;
    h=Date:From:To:Subject;
    b=ngqKYvq9aUf0Z5jhQFV+Zct1HXKjKzyjbOkLOWQfG0H33agEWQy7rA/eo9Cz4Zn5l
     1PBXqg8vAcY+OKMPfv2CPQrvmZgUJyLvFQtQkcj2RCJWLrtBDurh/WFlKJIzMiAwL+
     RqW4seoy/Q6uOBcCAL2IhRP5SBHCAw1J1sy5iYLk=
Date: Fri, 14 Aug 2020 10:36:29 +0800
From: root <root@paskal.my>
To: mizi <mizi@iwhost.com>
Message-ID: <b18836e2-41c1-482e-8e63-06815beaddc2@edison>
Subject: Testing
MIME-Version: 1.0

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I too was facing the email sending problem. Once, I executed the above command my all sites faced down. Both sites are down. I too tried creating several droplets just to check email sending problem and all of them didn’t work. Incoming emails comes without any problem but outgoing doesn’t delivers.

Hi @Paskal,

It seems like your port 25 is blocked. Please make sure your port is actually allowed in your firewall configuration. To do that, you can execute the following commands on your droplet :

sudo iptables -A OUTPUT -p tcp --dport 25 -m conntrack --ctstate NEW,ESTABLISHED -j ACCEPT
sudo iptables -A INPUT -p tcp --sport 25 -m conntrack --ctstate ESTABLISHED -j ACCEPT

If this doesn’t help, it might be possible DigitalOcean has closed off port 25. In that case, you’ll need to contact the support directly. You can reach them by going over to the following link

https://www.digitalocean.com/support/

Regards, KFSys