Question

Enable Mcrypt extension in NginX?

Hi all. After i installed phpMyAdmin on NginX, i found that mcrypt extension wasn’t enabled yet. I tried enabling mcrypt extension by this command :“sudo php5enmod mcrypt” and restart nginx. But it didn’t work. Please help me :)


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi Hoang!

I had the same issue however I am not using phpMyAdmin. I found this and it worked like a charm…

http://www.davekz.com/mcrypt-php-fpm-ubuntu/

apt-get install php5-mcrypt

Create symlink to mods-avaliable

ln -s /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available/mcrypt.ini

Enable It.

php5enmod mcrypt

Restart php-fpm

service php5-fpm restart

Restart nginx

sudo service nginx restart

This comment has been deleted

awesome!