Question

Enabled proxy protocol in load balancer causing CONNECT_CR_SRVR_HELLO:wrong version number error

Hi,

I have successfully installed my app on Kubernetes cluster. But I observed my app was seeing the local IP instead of actual client IP. So I enabled proxy protocol in load balancer and installed nginx-ingress as follows:

# Installing the Kubernetes Nginx Ingress Controller
helm install stable/nginx-ingress --name nginx-ingress --set controller.publishService.enabled=true,controller.config.use-forwarded-headers='"true"',controller.config.use-proxy-protocol='"true"'

But now I get the following error on accessing my API:

curl https://my-api.example.com/v3/status
curl: (35) error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number
Subscribe
Share

Hi there!

Can you check to ensure your service is configured properly to use proxy protocol via the DO LB: https://www.digitalocean.com/docs/kubernetes/how-to/configure-load-balancers/

Regards,

John Kwiatkoski Senior Developer Support Engineer


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!