Question

Enabling Let's Encrypt SSL certificate on Apache for 2 domain names

Hi,

I tried to get Let’s Encrypt certificates for both my www and non-www domain names, then redirect all the requests to my www domain with https scheme.

I installed certbot on my VPS, then I tried many attempts to get both certificates:

  1. I tried an all-in-one command: certbot --apache -d afa-advisory.com -d www.afa-advisory.com

  2. I tried the domain names separately in two commands: certbot --apache -d afa-advisory.com certbot --apache -d www.afa-advisory.com

  3. I tried expanding the first SSL certificate.

The problem is that I always get an invalid certificate for my root domain:

Invalid Common Name: Default Company Ltd


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Starting from a clean installation you should be able to set up this configuration using two -d flags for your www and non-www names as shown in #1 above. I recommend rebuilding your droplet with a clean LAMP install and then following this guide to set up your certificate.

If you encounter this problem or any other, please include your apache configuration files so we can review them and see any potential issues.