ERR_CONNECTION_REFUSED - WordPress - Ubuntu 16.04 - LetsEncrypt activated - Apache

August 12, 2018 1.6k views
CMS WordPress Ubuntu 16.04 Apache Let's Encrypt

Hello everybody !

First : sorry for my english, I’m french.......

Ok so, I have a big problem… I worked, with Google Chrome, on my website with WordPress, I made some changes on my site then, I just change actually page viewed : ERRCONNECTIONREFUSED....
So, I check on others browsers, with differents terminal (PC / MAC / mobile) with differents IPs but it’s the same....

Then, I check UFW status : all is good and all is activated) so I try to disable UFW : same thing.....
Then, I remove all my plugins on wordpress : same thing....
Then, I restart my apache service : same thing....

Then, I test “apache2ctl configtest” and all is good.

But when I check this file, chmod is 777 and is existing and is fully plain with a ssh key........

Can you help me please ?

Thanks for all !
Hugo

1 Answer

Hello,

In such cases what I could suggest is:

  • Check if your apache is actually listening on port 80 and 443, you can do that with:
netstat -plant
  • Check your Apache error log, maybe there is a problem with the SSL certificate which is preventing Apache from starting:
tail -100 /var/log/apache2/error.log
  • Try to remove the Vhost created by certbot, restart apache and then try to reissue Let’s Encrypt again.

Regards,
Bobby

Have another answer? Share your knowledge.