ERR_TOO_MANY_REDIRECTS agreestat.net redirected you too many times.

October 10, 2019 70 views
Security

Hi,
I just set up SSL with my web app following the instructions provided in the document “https://www.digitalocean.com/community/tutorials/how-to-set-up-shiny-server-on-ubuntu-16-04.” But since doing it, I have been getting the error “ERRTOOMANY_REDIRECTS”. Would my NGINX file be the problem? In case it can help, here is my NGINX file:

server {
   listen 80 default_server;
   listen [::]:80 default_server ipv6only=on;
   server_name agreestat.net www.agreestat.net;
   return 301 https://$server_name$request_uri;
}
server {
   listen 443 ssl;
   server_name agreestat.net www.agreestat.net;
   ssl_certificate /etc/letsencrypt/live/example.com/fullchain.pem;
   ssl_certificate_key /etc/letsencrypt/live/example.com/privkey.pem;
   ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
   ssl_prefer_server_ciphers on;
   ssl_ciphers AES256+EECDH:AES256+EDH:!aNULL;

   location / {
       proxy_pass http://67.207.84.153:3838;
       proxy_redirect http://67.207.84.153:3838/ https://$host/;
       proxy_http_version 1.1;
       proxy_set_header Upgrade $http_upgrade;
       proxy_set_header Connection $connection_upgrade;
       proxy_read_timeout 20d;
   }
}
1 Answer

Hello, @gwet

Can you try modifying the port80 server block to:

server {
   listen 80;
   listen [::]:80;
   server_name agreestat.net www.agreestat.net;
   return 301 https://$server_name$request_uri;
}

Test the nginx config file for syntax errors:

nginx -t

If all is good, restart and try again.

Let me know how it goes.

  • Hi,
    Thanks for your reply. I was able to make it work on Microsoft Edge (it actually works fine there). But I am still experiencing problems with google chrome. Maybe it has something to do with chrome’s settings.

    • If everything is working fine on Edge, then you can clear the browser’s history cache and clear the cookies. You can also open an incognito session in Chrome (Ctrl+Shift+N) and see how it works there. You can also open the site in third browser as well.

      Let me know how it goes.

      • After clearing chrome’s history cache and cookies, everything is now working as I like it. Thank you very much alexdo for all the assistance.

        • I’m glad this is sorted! Feel free to ask if there is anything else! Have a great day! :)

Have another answer? Share your knowledge.