Question

Error 1819 when setting up phpmyadmin on Nginx Ubuntu 20.04

As I was following this tutorial https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-with-nginx-on-an-ubuntu-18-04-server, I immediately got an error after this step in the first paragraph:

*Next, you’ll be prompted whether to use dbconfig-common for configuring the application database. Select Yes. *

This is the error:

mysql said: ERROR 1819 (HY000) at line 1: Your password does not satisfy the current policy requirements. 

I find this quite odd, since I didn’t even enter a password yet. I think maybe this has something to do with me installing on Ubuntu 20.04 and not 18.04.

Any word of advice on how to proceed?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @katovonkatz,

It’s okay to use it on both Ubuntu 20.04 and 18.04. Having said that, can you let me know if this message appeared right after you ran the command

dbconfig-common

One other thing, before following this tutorial I take it you’ve had MySQL installed, did you run the

mysql_secure_installation

option then?

Regards, KFSys

A quick and incorrect solution is to remove MYSQL password validation, install phpmyadmin, then install password validation.

Step 1: Log into MYSQL as root and verify it’s installed with command: SHOW VARIABLES LIKE ‘validate_password%’; If it is, you will see something similar to below: ±-------------------------------------±------+ | Variable_name | Value | ±-------------------------------------±------+ | validate_password.check_user_name | ON | | validate_password.dictionary_file | | | validate_password.length | 6 | | validate_password.mixed_case_count | 1 | | validate_password.number_count | 1 | | validate_password.policy | LOW | | validate_password.special_char_count | 1 | ±-------------------------------------±------+

*Note - You may wish to copy this output so you can reconfigure the component when you reinstall it in step 4.

Step 2: Uninstall the validate_password component with command: UNINSTALL COMPONENT ‘file://component_validate_password’;

Step 3: Reinstall phpmyadmin.

Step 4: Install the validate_password component with command: INSTALL PLUGIN validate_password SONAME ‘validate_password.so’;

I got this issue on the process of phpmyadmin installation.