Hi, friends

Recently i got a notification from Youtube in which they said my API would be deactivated. I did not know what to do with this information and the day came when it was deactivated. My site now is giving the message Error establishing a database connection.

I am with the step by step orientation to debug the issue, but i am suspecting the reason it happened is the one issue with youtube.

If it is indeed this reason – i don’t believe it ran out of memory or something the like – i should be able to turn off those plugins related to youtube and the site will come back.

Would be so kind to help me solve this problem?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hi, Praveen.

indeed.
Thanks so much!

  • Hello,

    Now you need to debug the database. To do that, login to the droplet then edit the wp-config.php file. You can do this via terminal or ftp client. Add it just before ‘That’s all, stop editing! Happy blogging’ line wp-config.php.

    define('WP_ALLOW_REPAIR', true);
    

    Once you have done that, you can see the settings by visiting this page:

    http://www.domain.com/wp-admin/maint/repair.php
    

    Hope this helps.
    Praveen.

Hello. Did you try rebooting the droplet? Mostly, this does fix the issue.

Hope this helps.
Praveen.

could be mysql running out of memory, i fixed restarting mysql.
systemctl start mysql

Submit an Answer