minhbkx
By:
minhbkx

Error establishing a database connection without heavy load

February 3, 2015 1.6k views

Hello all,

Usually my droplet is using 25-30% of the memory, CPU. But sometimes it was increase nearly 100%. Im using a 4gb droplet
then it kill the database and led to Error establishing a database connection.
No increase in the site's traffic.
Then I restarted the mysql server and it was good for a while, then the error repeated again.

What would be the problem? And how can i check the server log
im using wordpress, centos and im just a non-tech newbie.

Thanks for all your help.
Minh

4 comments
  • Two things to check:

    sometimes a plugin or theme can cause this. You can check by disabling plugins one by one...wait...wait..and see if the problem continues. If not, then re-enable that plugin and try the next one.
    It is surprising how plugins can sometimes do this.

    Also, Wordpress will often have brute-force attacks. This traffic will not show as regular traffic. You can use the plugin "Login Lockdown" to help. Also, you can change the login page in Wordpress from wp-login.php to something else.
    I do this on all Wordpress sites I manage, and it makes a lot of difference.

    Google to find how to do this..It is not very difficult

  • I would recommend you check your domain access log (requests.log) and grep for wp-login. You can also grep the log for the word "POST."

    Finally you should check to see if there is a single ip address that is repeatedly hitting your site more frequently than others. It could be that your site is being hit by bot traffic. You might want to use a robots.txt file to block the more aggressive bots.

  • Try this:

    #change logfile to the location of your log file.
    logfile='/var/log/apache2/sundayhelp.com-access.log'
    for i in `cat $logfile|awk '{print $1}'|sort -u`;do count=`grep -c $i $logfile`;echo "$i;$count";done > ip_count.csv
    

    The ipcount.csv_ file will have IP, NUMBEROF_TIMESSEEN

    the other alternative is installing goaccess

  • thanks you all. your guides look very helpful.
    i will check it out.

1 Answer

This question was answered by @sierracircle:

Two things to check:

sometimes a plugin or theme can cause this. You can check by disabling plugins one by one...wait...wait..and see if the problem continues. If not, then re-enable that plugin and try the next one.
It is surprising how plugins can sometimes do this.

Also, Wordpress will often have brute-force attacks. This traffic will not show as regular traffic. You can use the plugin "Login Lockdown" to help. Also, you can change the login page in Wordpress from wp-login.php to something else.
I do this on all Wordpress sites I manage, and it makes a lot of difference.

Google to find how to do this..It is not very difficult

View the original comment

Have another answer? Share your knowledge.