Question

error establishing database connection?

I am getting this error over and over again and when I try to solve this by following an article by digitalocean I get this error “sudo: netstat: command not found”


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @umarzaib136,

Can you please let me know which article you are following?

Additionally, if you don’t have the netstat command, you can always install it by doing:

For Ubuntu

apt install netstat

For CentOS

yum install netstat

As for the error establishing database connection, it can be related to a lot of stuff. Your website might be using the wrong credentials to connect to your Database, your MySQL service might be down or you don’t have any.

As such, can you please provide us with a little bit more information what is your setup, has this worked before, have you made any changes recently if it worked before and basically, all the information you can think of?