Question

Error in installing phpMyadmin

Posted January 26, 2014 7.4k views
Hi, I follow the instruction here to install phpmyadmin: (https://www.digitalocean.com/community/articles/how-to-install-and-secure-phpmyadmin-on-a-centos-6-4-vps) But when I writte command "sudo yum install phpmyadmin", this error shows up: ========================================================== Error: Package: php-gd-5.3.3-27.el6_5.x86_64 (updates) Requires: php-common(x86-64) = 5.3.3-27.el6_5 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php-common(x86-64) = 5.4.24-1.el6.remi Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(api) = 20090626 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php(api) = 20100412-x86-64 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Error: Package: php-cli-5.3.3-27.el6_5.x86_64 (updates) Requires: php-common(x86-64) = 5.3.3-27.el6_5 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php-common(x86-64) = 5.4.24-1.el6.remi Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Error: Package: php-mbstring-5.3.3-27.el6_5.x86_64 (updates) Requires: php-common(x86-64) = 5.3.3-27.el6_5 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php-common(x86-64) = 5.4.24-1.el6.remi Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Error: Package: php-5.3.3-27.el6_5.x86_64 (updates) Requires: php-common(x86-64) = 5.3.3-27.el6_5 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php-common(x86-64) = 5.4.24-1.el6.remi Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(zend-abi) = 20090626 Installed: php-common-5.4.24-1.el6.remi.x86_64 (@remi) php(zend-abi) = 20100525-x86-64 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Available: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest ========================================================== COULD YOU HELP ME PLEASE

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers
Try running the following command instead:
sudo yum install phpmyadmin --enablerepo remi
I dont know him but its worked for me, thank you so much.

I got the same error, but the command above doesn’t worked for me :(

Submit an Answer