Question

Error in iredmail for not being able to send mail

Diagnostic-Code: X-Postfix; connect to 127.0.0.1[127.0.0.1]:10024: Connection refused.

Anyone know what this is about?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

SOLVED you have to have 1G mem to use iredmail or do this: <br> <br>Stop virus/spam scanning, keep DKIM signing/verification and Disclaimer <br> <br>If you want to disable virus and spam scanning, but keep DKIM signing and disclaimer, please try this: <br>Keep “content_filter =” setting in Postfix main.cf. <br>File: main.cf <br>content_filter = smtp-amavis:[127.0.0.1]:10024 <br>Find below lines in /etc/amavisd/amavisd.conf: <br>File: amavisd.conf <br># @bypass_virus_checks_maps = (1); # controls running of anti-virus code <br># @bypass_spam_checks_maps = (1); # controls running of anti-spam code <br>Uncomment above lines (removing "# " at the beginning of each line), and restart Amavisd service. <br> <br>Completely disable all features <br>I had to completely disable spam and virus scanning services <br>If you want to completely disable spam and virus scanning services, steps: <br>Comment out ‘content_filter = smtp-amavis:[127.0.0.1]:10024’ in Postfix config file main.cf, and restart Postfix service. <br>Disable network services: Amavisd, ClamAV. <br>Notes: <br>ClamAV and SpamAssassin will be invoked by Amavisd, so if you disable Amavisd, those two are disabled too. <br>SpamAssassin doesn’t have daemon service running in iRedMail solution, so there’s no need to stop SpamAssassin service. <br> <br>Thinking about a larger droplet <br> <br>update-rc.d -f amavis disable
<br>amavis won’t start at boot anymore. <br>keeps amavis from starting at boot.

restart Amavis and check again.

I can receive emails but cannot send. My log says:

connect to aspmx2.googlemail.com[64.233.186.26]:25: Connection timed out

I have research all over the web, but without success :(