Error in iredmail for not being able to send mail

Posted April 23, 2014 6.7k views
Diagnostic-Code: X-Postfix; connect to[]:10024: Connection refused. Anyone know what this is about?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
4 answers
SOLVED you have to have 1G mem to use iredmail or do this:

Stop virus/spam scanning, keep DKIM signing/verification and Disclaimer

If you want to disable virus and spam scanning, but keep DKIM signing and disclaimer, please try this:
Keep "content_filter =" setting in Postfix
content_filter = smtp-amavis:[]:10024
Find below lines in /etc/amavisd/amavisd.conf:
File: amavisd.conf
# @bypass_virus_checks_maps = (1); # controls running of anti-virus code
# @bypass_spam_checks_maps = (1); # controls running of anti-spam code
Uncomment above lines (removing "# " at the beginning of each line), and restart Amavisd service.

Completely disable all features
I had to completely disable spam and virus scanning services
If you want to completely disable spam and virus scanning services, steps:
Comment out 'content_filter = smtp-amavis:[]:10024' in Postfix config file, and restart Postfix service.
Disable network services: Amavisd, ClamAV.
ClamAV and SpamAssassin will be invoked by Amavisd, so if you disable Amavisd, those two are disabled too.
SpamAssassin doesn't have daemon service running in iRedMail solution, so there's no need to stop SpamAssassin service.

Thinking about a larger droplet

update-rc.d -f amavis disable
amavis won't start at boot anymore.
keeps amavis from starting at boot.
An error message like that is usually a cue to start digging through logs. The logs will give you clues to where the problem is.
It would be helpful to know what you have tried so far.
Have you applied your Google-fu to this problem yet?

I can receive emails but cannot send. My log says:

connect to[]:25: Connection timed out

I have research all over the web, but without success :(

restart Amavis and check again.