Question

Error - Installing mod_pagespeed on CentOS 6.6

Hi,

I followed this guide to install mod_pagespeed on a CentOS 6.6 https://www.digitalocean.com/community/tutorials/how-to-get-started-with-mod_pagespeed-with-apache-on-a-centos-and-fedora-cloud-server

While installing I get this error: error: Failed dependencies: httpd >= 2.2 is needed by mod-pagespeed-stable-1.9.32.3-4448.x86_64

Can anyone tell me whats wrong?

I tried to restart the apache server.

Thanks

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Oddly, when I run the installer with this:

[root@zenoss-centos ~]# yum -y install at;rpm -Uvh https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm

Then I run this:

service httpd restart; httpd -M |grep page

I get this:

 pagespeed_module (shared)
Syntax OK

Now, I check which HTTPD version I’m running:

[root@zenoss-centos ~]# httpd -v
Server version: Apache/2.2.15 (Unix)
Server built:   Oct 16 2014 14:48:21

Try just running the command I have outlined above:

yum -y install at;rpm -Uvh https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm