Question

Error - php7.0-fpm.sock failed [NGINX - Ubuntu Server]

Respected, I’m facing php7.0-fpm.sock failed error from a long time on Ubuntu 16.04.5 LTS (NGINX). Six websites are active on this server.

Kindly check below detailed logs.

php7.0-fpm.log:

2018/09/04 06:25:04 [error] 18209#18209: *362673 connect() to unix:/run/php/php7.0-fpm.sock failed (11: Resource temporarily unavailable) while connecting to upstream, client: 162.158.126.43, server: [domain_name_hidden].com, request: “GET / HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.0-fpm.sock:”, host: “[domain_name_hidden].com”

error.log:

[02-Sep-2018 06:25:02] NOTICE: error log file re-opened [04-Sep-2018 09:19:40] NOTICE: Terminating … [04-Sep-2018 09:19:41] NOTICE: exiting, bye-bye! [04-Sep-2018 09:19:57] NOTICE: configuration file /etc/php/7.0/fpm/php-fpm.conf test is successful [04-Sep-2018 09:19:57] NOTICE: fpm is running, pid 1745 [04-Sep-2018 09:19:57] NOTICE: ready to handle connections [04-Sep-2018 09:19:57] NOTICE: systemd monitor interval set to 10000ms [04-Sep-2018 19:53:56] WARNING: [pool www] server reached pm.max_children setting (5), consider raising it

If reboot the server then websites are working for a limited period (Approximately 5-7 hours). Another fix, I need to restart the PHP FPM through the following command: sudo service php7.0-fpm restart

Please help. Thank you!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have changed root from unix:/run/php/php7.0-fpm.sock to unix:/var/run/php/php7.0-fpm.sock in Nginx Conf and Sites-available files for the testing purpose. I’ll update soon if the error appears again.

Here’s a summary of what fixed this error: In /etc/php/7.0/fpm/pool.d/www.conf change the lines as below: listen = /var/run/php/php7.0-fpm.sock In /etc/nginx/sites-available/your_site.conf: Under “location ~ .php$ {” change the line to: fastcgi_pass unix:/var/run/php/php7.0-fpm.sock; Restart nginx: sudo service nginx restart Everything should then work.