Question

Error updating do-agent

I’m trying to install the new version of the do-agent following the tutorial. first I remove the old do-agent package then I try to execute curl -sSL https://insights.nyc3.cdn.digitaloceanspaces.com/install.sh | sudo bash

running this command returns me an error:

Cleaning up old sources...OK
Verifying machine compatability...OK
Verifying compatability with script...OK
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package do-agent
Installing apt repository...
E: Failed to fetch http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu/dists/bionic/InRelease  403  Forbidden [IP: 91.189.95.83 80]
E: The repository 'http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu bionic InRelease' is not signed.
Installing gpg key...OK
E: Failed to fetch http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu/dists/bionic/InRelease  403  Forbidden [IP: 91.189.95.83 80]
E: The repository 'http://ppa.launchpad.net/nijel/phpmyadmin/ubuntu bionic InRelease' is not signed.

I am running a 18.04 Ubuntu VM.

Can someone help me solving the problem? Thank you in advance,

Simone


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I think the solution is simple, you just need to disable the non-existing repository (nijel/phpmyadmin).