Question

[error] * upstream timed out (110: Connection timed out) while reading response header from upstream

So I recently deployed a Ruby on Rails app using Nginx, Unicorn, and Capistrano. Everything was working great (and I had used cap :deploy) to deploy changes. Made some recent changes to my site, deployed today and am getting these errors in my nginx/error.log

2013/07/19 19:05:16 [error] 21484#0: *8 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 67.180.201.178, server: , request: “GET / HTTP/1.1”, upstream: “http://unix:/tmp/unicorn.socialmath.sock:/”, host: “mrbarrette.com

I’ve tried google, but haven’t found anything that worked. Any thoughts on where to look for a fix or an idea for a fix? Thanks much in advance!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am sorry, I think I have the same issue as you. <br>But I still dont know how to fix it from your solutions. <br>Can you tell more about it?

Thanks. Had the same problem

You’re welcome, good to hear you solved it!