Question

Error when changing ports of my App

When I changed the listen port (in my Nest server code) from 3000 to 80, and the DO component port from 3000 to 80, App deployments failed with the following message:

ERROR: failed to initialize cache: failed to create image cache: accessing cache image <registry-uri> connect to repo store <registry-uri> GET <do-api-uri> unexpected status code 401 Unauthorized: {"id": "Unauthorized", "message": "Unable to authenticate you" }

I changed them both back and it deployed just fine.

Quacks like a bug. Any idea?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello @SandyGrayDolphin

This error doesn’t seem to be related to port change but might be coincident that upload to the internal container registry failed at the same time. That appears to be transient issue and you should be able to update the port and it might work on next attempt. Please give it a try once again.

If the issue persists then please reach out to support team for help.

Thanks, Dikshith