Question

Error when running docker daemon

Hi, i just bought my Debian 9 VPS,followed the tutorial to install docker and tried to run my docker project. But firstly i got this error:

INFO[2021-06-04T15:55:01.566710794Z] Starting up                                  
failed to start daemon: pid file found, ensure docker is not running or delete /var/run/docker.pid

I deleted the PID file and then this error came:

INFO[2021-06-04T15:53:13.559081445Z] Starting up                                  
INFO[2021-06-04T15:53:13.561387278Z] parsed scheme: "unix"                         module=grpc
INFO[2021-06-04T15:53:13.561516232Z] scheme "unix" not registered, fallback to default scheme  module=grpc
INFO[2021-06-04T15:53:13.561653000Z] ccResolverWrapper: sending update to cc: {[{unix:///run/containerd/containerd.sock 0  <nil>}] <nil>}  module=grpc
INFO[2021-06-04T15:53:13.561728791Z] ClientConn switching balancer to "pick_first"  module=grpc
INFO[2021-06-04T15:53:13.563173017Z] parsed scheme: "unix"                         module=grpc
INFO[2021-06-04T15:53:13.563257881Z] scheme "unix" not registered, fallback to default scheme  module=grpc
INFO[2021-06-04T15:53:13.563334916Z] ccResolverWrapper: sending update to cc: {[{unix:///run/containerd/containerd.sock 0  <nil>}] <nil>}  module=grpc
INFO[2021-06-04T15:53:13.563401769Z] ClientConn switching balancer to "pick_first"  module=grpc
INFO[2021-06-04T15:53:13.569060266Z] [graphdriver] using prior storage driver: overlay2 
failed to start daemon: error while opening volume store metadata database: timeout

Both command were launched with sudo dockerd.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Did you get this solved? We have the same problem

Did you get this solved? we have the same problem

Hi there,

When checking the status of the Docker daemon does it report back as running:

systemctl status docker

If not, does it start after a restart:

sudo systemctl restart docker

If you still get the error you could try killing the Docker process and then try to start it again:

ps axf | grep docker | grep -v grep | awk '{print "kill -9 " $1}' | sudo sh 

To start it run:

sudo systemctl start docker

Feel free to share the output of the commands here if this still does not work.

Regards, Bobby