Question

Error when using PPTP server on VPS: compressor dropped pkt

Hello, when setting up my VPN I used this tutorial: https://www.digitalocean.com/community/articles/how-to-setup-your-own-vpn-with-pptp

It works but when I connect to it, it is very slow and only a few websites load. I have gone and viewed the logs file for errors and it says: PPP: compressor dropped pkt

I’ve tried the same thing on another droplet but I get the same problem. Also, I have tried searching Google but the only results I get aren’t for Ubuntu.

If anyone has any advice I’d appreciate it and follow through. For the time being, I am using openvpn connect.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I had the same problem on centos 6.5, some pages simply wont load, however I just added

ifconfig $1 mtu 1400

to /etc/ppp/ip-up and it worked

The comment’s didn’t work so just go to: http://danielsokolowski.blogspot.com/2013_04_01_archive.html

Hey guys, I’ve fixed the problem, You’ve gotta do: <br> <br>Below is my workaround script, place it into file ‘/etc/ppp/ip-up.d/mppefixmtu’ and ensure that it is executable (‘chmod +x mppefixmtu’): <br> <br>#!/bin/sh <br>CURRENT_MTU=“ifconfig $1 | grep -Po '(?<=MTU:)([0-9]+)'” <br>FIXED_MTU=“expr $CURRENT_MTU + 4” <br>ifconfig $1 mtu $FIXED_MTU <br>echo “Increased MTU for $1 to $FIXED_MTU (from $CURRENT_MTU) to fix MPPE Microsoft Point-to-Point bug #330973” <br> <br>Taken from: http://danielsokolowski.blogspot.com/2013_04_01_archive.html