Sebi
By:
Sebi

Error while deploying via Capistrano

October 23, 2014 1.8k views

Hello!

I try to set up Capistrano right to use it for deploying a rails-app to the DigitalOcean-Droplet. Files seem to be deployed but I get the following error:

INFO[84def4b2] Running ~/.rvm/bin/rvm default do bundle exec rake assets:precompile on 178.62.197.29
DEBUG[84def4b2] Command: cd /home/deploy/my_app/releases/20141023212604 && ( RAILS_ENV=production ~/.rvm/bin/rvm default do bundle exec rake assets:precompile )
DEBUG[84def4b2]     rake aborted!
DEBUG[84def4b2]     Could not find cache store adapter for dalli_store (cannot load such file -- dalli)
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:105:in `rescue in retrieve_store_class'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
DEBUG[84def4b2]     /home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
DEBUG[84def4b2]     LoadError: cannot load such file -- dalli
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache/dalli_store.rb:2:in `<top (required)>'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
DEBUG[84def4b2]     /home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
DEBUG[84def4b2]     /home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
DEBUG[84def4b2]     Tasks: TOP => environment
DEBUG[84def4b2]     (See full trace by running task with --trace)
cap aborted!
SSHKit::Runner::ExecuteError: Exception while executing on host 178.62.197.29: rake exit status: 1
rake stdout: Nothing written
rake stderr: rake aborted!
Could not find cache store adapter for dalli_store (cannot load such file -- dalli)
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:105:in `rescue in retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
LoadError: cannot load such file -- dalli
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache/dalli_store.rb:2:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
Tasks: TOP => environment
(See full trace by running task with --trace)
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/command.rb:97:in `exit_status='
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:148:in `block (5 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:551:in `call'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:551:in `do_request'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:561:in `channel_request'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:465:in `dispatch_incoming_packets'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:221:in `preprocess'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:205:in `process'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `block in loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:269:in `wait'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:170:in `block (3 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:514:in `call'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:514:in `do_open_confirmation'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:545:in `channel_open_confirmation'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:465:in `dispatch_incoming_packets'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:221:in `preprocess'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:205:in `process'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `block in loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:172:in `block (2 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:186:in `with_ssh'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:131:in `block in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:128:in `tap'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:128:in `_execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:66:in `execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:59:in `block (6 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/abstract.rb:85:in `with'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:58:in `block (5 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/abstract.rb:77:in `within'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:57:in `block (4 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:54:in `instance_exec'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:54:in `run'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/runners/parallel.rb:13:in `block (2 levels) in execute'
SSHKit::Command::Failed: rake exit status: 1
rake stdout: Nothing written
rake stderr: rake aborted!
Could not find cache store adapter for dalli_store (cannot load such file -- dalli)
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:105:in `rescue in retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
LoadError: cannot load such file -- dalli
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache/dalli_store.rb:2:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
Tasks: TOP => environment
(See full trace by running task with --trace)
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/command.rb:97:in `exit_status='
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:148:in `block (5 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:551:in `call'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:551:in `do_request'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:561:in `channel_request'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:465:in `dispatch_incoming_packets'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:221:in `preprocess'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:205:in `process'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `block in loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:269:in `wait'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:170:in `block (3 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:514:in `call'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/channel.rb:514:in `do_open_confirmation'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:545:in `channel_open_confirmation'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:465:in `dispatch_incoming_packets'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:221:in `preprocess'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:205:in `process'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `block in loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/net-ssh-2.9.1/lib/net/ssh/connection/session.rb:169:in `loop'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:172:in `block (2 levels) in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:186:in `with_ssh'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:131:in `block in _execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:128:in `tap'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:128:in `_execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:66:in `execute'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:59:in `block (6 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/abstract.rb:85:in `with'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:58:in `block (5 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/abstract.rb:77:in `within'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/capistrano-rails-1.1.2/lib/capistrano/tasks/assets.rake:57:in `block (4 levels) in <top (required)>'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:54:in `instance_exec'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/backends/netssh.rb:54:in `run'
/Users/sebastian/.rvm/gems/ruby-2.1.3/gems/sshkit-1.5.1/lib/sshkit/runners/parallel.rb:13:in `block (2 levels) in execute'
Tasks: TOP => deploy:assets:precompile
(See full trace by running task with --trace)
The deploy has failed with an error: #<SSHKit::Runner::ExecuteError: Exception while executing on host 178.62.197.29: rake exit status: 1
rake stdout: Nothing written
rake stderr: rake aborted!
Could not find cache store adapter for dalli_store (cannot load such file -- dalli)
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:105:in `rescue in retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
LoadError: cannot load such file -- dalli
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache/dalli_store.rb:2:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:103:in `retrieve_store_class'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/cache.rb:59:in `lookup_store'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application/bootstrap.rb:62:in `block in <module:Bootstrap>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `instance_exec'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in `run'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in `block in run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in `run_initializers'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in `initialize!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `public_send'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/railtie.rb:194:in `method_missing'
/home/deploy/my_app/releases/20141023212604/config/environment.rb:5:in `<top (required)>'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:276:in `require_environment!'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:389:in `block in run_tasks_blocks'
/home/deploy/my_app/shared/bundle/ruby/2.1.0/gems/sprockets-rails-2.2.0/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'
Tasks: TOP => environment
(See full trace by running task with --trace)

Thanks for your help!

1 Answer

It looks like the key error here is:

LoadError: cannot load such file -- dalli

You seem to be missing a dependency. You need to add gem 'dalli' to your Gemfile

Have another answer? Share your knowledge.