Question

Error while trying to upgrade nginx

I am trying to upgrade NGINX to the latest stable but keep getting this error:

Preparing to unpack .../nginx_1.8.0-1~trusty_amd64.deb ...
Unpacking nginx (1.8.0-1~trusty) over (1.4.6-1ubuntu3.3) ...
dpkg: error processing archive /var/cache/apt/archives/nginx_1.8.0-1~trusty_amd64.deb (--unpack):
 trying to overwrite '/etc/logrotate.d/nginx', which is also in package nginx-common 1.4.6-1ubuntu3.3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/nginx_1.8.0-1~trusty_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I hav tried to upgrade to the mainline also but same errror. What am I missing?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @damir:

Hi I solved the problem almost instantly after my report regarding the blank page!

The problem is in the config files. Make sure that the correct site is active and not the deafult NGINX welcome site! Check the paths!

You can see the comment here.